Tizen target dropped?

okay i think i finally grasped the scope of this problem.
compiling hxcpp went well, but the current lime build uses a lot of now defunct apis.

i did some research though and today sdk version 2.3.1 rev1 was released with the anouncement that the upcoming sdk 2.4 rev1 will suport both platforms. i hope the apis will be compatible, or at least not as wildly different as from 2.2 to 2.3.


aaand a milestone for tizen 3.0 is to keep api compatibility to 2.4.


so i think it’s pretty save to start using 2.4 for this.

soooo. you earlier said one should try to build the tizen project with HXCPP… is there documentation on how i should go about that somewhere? otherwise i’ll just kepp going down my current path of googling and trial&error. :wink:

Well, even before HXCPP, some combination of SDK and device software that works with existing Tizen samples is a promising start. If those don’t work for us, integrating the same type of code into Lime won’t help :smile:

So is there an SDK 2.3.1 or 2.4 update to the Z1 hardware? Does 2.3.1 work with the device as-is? I downloaded the 2.3 SDK (maybe it was 2.3.1) I think we could start there if that’s all the hardware supports. In 2.2, I saw discrepancies between hardware and simulator – I don’t trust simulators usually :wink:

The hardware accelerated flag is REALLY important for performance. I remember the night I discovered it, and realized why everything was slow :sweat_smile:

Have we had any luck with samples yet?

well just using the native sdk without anything out of the lime ecosystem, i have got the glviewcube sample working with sdk 2.3.1 and the newest firmware version that i got over the air via the normal update. that is (z130hdduob0H1)
i just had to remove the acceleration flag though… :confused:

in the code there is the line


docs: https://developer.tizen.org/dev-guide/2.3.0/org.tizen.native.mobile.apireference/group__Engine.html#ga5bffe9d8bd36424943aa8d20ac148027

though. i think that takes care of it. i hope… :worried:

I just got as well, I tried 2.4 beta but registrations are closed :frowning:

They say 2.3.1 is the match for the Z1, though, likely after this OTA update. This sounds promising. I assume that preference done in the C++ code triggers it?

Hi Josh, hi everybody in the OpenFL community!

… I guess it’s fair to say, that Tizen support from OpenFL is pretty much dropped in the moment …
Is this how it’s going to stay, or are there any other plans?

Any if it would be eventually revived, would it merely deal with the HTML5 Tizen target,
or even enable native Tizen c++ apps?!?

Thanks a lot for keeping us up to date,

Hi again!

Just saw your reply on the other Tizen related thread …

…so I know the status quo from June 2016 now…
Anything has changed since then?


It looks like they do not have SDL2 support, though it has been discussed (it seems) in a few places.

Without SDL2, there is a lot of work needed on our part to support a Tizen target. I’m not sure this is something we can do given our current resources, but I would be open to including source files if someone else were to do this work.

I think that HTML5 is probably the most practical form of support for Tizen, as that doesn’t require additional (special) testing. Would that work properly for your needs? What are you looking for?

Hi Josh, thanks for quick response …

More or less I am looking for a comfortable and not restrictive way to do
some development for Smartwatches (like Samsung Gear S2 and S3 … a.t.l.), which are running on Tizen (SDK 2.3.1 and above)…

I am aware that this will not be possible entirely without the TIZEN IDE (for basic project layout
& signing process ), but maybe OpenFL could come in handy in the (graphical) design process…
so I guess that some basic HTML5 support (displaying bitmaps, basic animations) would suffice for the moment … (I will make a short test with OpenFL html5 target for that matter - to see what is still missing
for me … )

I am just evaluating the possibilities at the moment …
and it looks like that all the Tizen efforts in the Haxe community happened around 2 years ago,
when Tizen SDK 2.2 was new (and hot) and then the whole thing cooled down again …

I think I explained the scenario, where they a.) deprecated the APIs we used, b.) did not release an update for our testing device and c.) stopped allowing downloads of the older SDK. This effectively killed all the work I did to support their platform :frowning:

Please let me know what you find, we have canvas and WebGL as options, and may run suitably. I’d be happy to support Tizen in the Lime tools, as HTML5, it would require templates and coordination with the Tizen SDK tools, but otherwise won’t require writing a whole new platform target. I think it could be a win :slight_smile:

will there be a reconsideration for tizen support in the future? tried working with html5 web app for tizen, and it seems there are lots of homework to do on html5 as well.

Tizen Native SDK which is based on C++ is still on development, will this be in sync with openfl development? If yes, then it would be nice to have tizen native support as nowadays tizen is used for samsung wearable and phones.


Tizen support for the SDL API is very promising! I wonder (though) if it is working for SDL + OpenGL, or it only is SDL + Vulkan, in which case we would need to write a Vulkan renderer for OpenFL for it to work.

Are you more interested in Tizen wearable, or Tizen phones?

I wonder if Tizen HTML5 runs better on the watch than Tizen native

What did you find out about Tizen HTML5 development? If you can get an index.html running, perhaps we can try and replace with our generated HTML and see if it works? You might need -Dcanvas if WebGL is not supported?

i can get index.html to work on samsung z2, but there is still lots of missing feature. the worst one is i cant get swf asset to work.

Perhaps it would be worth trying OpenFL samples, like DisplayingABitmap, AddingAnimation, PlayingSound, AddingText then PiratePig

If we try multiple samples, we should be able to isolate which features are not behaving. Perhaps it doesn’t like the “*.dat” file extension we used for SWF asset data?

HTML5 is probably our fastest approach to support the platform short-term, we could move to native again later if SDL + OpenGL works out (or if we add a Vulkan renderer)

is there anything we can do to fix swf asset loading problem quickly? in fact im on tight dealine for tizen challenge and want to know if i can enter the challenge or just skip it, because my game rely on swf asset

If you can, try some of the OpenFL samples, and see if they work. If we confirm that DisplayingABitmap works, but NyanCat fails, and get an error information, then I think we can try and resolve it

Thanks for your help :slight_smile:

I can confirm that DisplayingABitmap works on Samsung Z2 using html5 port, while NyanCat fails to load, and just stops at preloader bar screen with following error messages:

Error: [lime.app.Preloader] ERROR: [IOErrorEvent type="ioError" bubbles=true cancelable=false text="0" errorID=0] 
Error: [lime.app.Preloader] ERROR: Error loading asset "assets/library.swf"

AddingText demo seems to be not working as well with following error message

Error: [lime.app.Preloader] ERROR: Error loading asset "assets/KatamotzIkasi.woff" AddingText.js:32209
Error: [lime.app.Preloader] ERROR: Error loading asset "assets/KatamotzIkasi.eot" AddingText.js:32209
Error: [lime.app.Preloader] ERROR: Error loading asset "assets/KatamotzIkasi.svg" AddingText.js:32209

PiratePig demo works

Could you try this fix on NyanCat?

Thanks, but still not working, now down to one error only

Error: [lime.app.Preloader] ERROR: [IOErrorEvent type="ioError" bubbles=true cancelable=false text="0" errorID=0]

game opened, and stuck on preloader bar screen

Can you try embed="true" on your assets or library tags?

same thing

Error: [lime.app.Preloader] ERROR: [IOErrorEvent type="ioError" bubbles=true cancelable=false text="0" errorID=0] NyanCat.js:32143

if only there is more to the error message, maybe we can dig deeper. But I don’t think we can get the call stack from html5 debugging

this is the project.xml

<?xml version="1.0" encoding="utf-8"?>

<meta title="Nyan Cat" package="org.openfl.samples.nyancat" version="1.0.0" company="OpenFL" />
<app main="Main" path="Export" file="NyanCat" />

<window width="400" height="400" fps="30" />

<source path="Source" />

<haxelib name="openfl" />

<library path="Assets/library.swf" preload="true" embed="true" />

<!-- <assets path="Assets" rename="assets" /> -->