OpenFL 8.9.4 / Lime 7.6.2


8.9.4 (09/05/2019)

  • Reverted UTF character changes to investigate a different fix
  • Fixed support for 64-bit Neko on Windows (included in Haxe 4 RC 4)
  • Fixed a possible issue when using @:bitmap assets on HTML5

8.9.3 (09/04/2019)

  • Updated for Haxe 4 RC 4
  • Improved the quality of scale9Grid rendering in hardware
  • Improved support for rendering UTF character sets with TextField
  • Fixed a type error when running on C++ platforms
  • Fixed incorrect scale value when using openfl.geom.Transform
  • Fixed support for array-based form parameters when making HTTP requests
  • Fixed use of an incompatible OpenGL call when using the Electron target
  • Fixed reference to objects that could prevent GC in event pool behavior
  • Fixed the value for the ClipboardFormats.TEXT_FORMAT type


7.6.2 (09/05/2019)

  • Fixed support for 64-bit Neko on Windows (included in Haxe 4 RC 4)

7.6.1 (09/04/2019)

  • Fixed support for array-based form parameters when making HTTP requests
  • Fixed incorrect default root path for asset manifests on some platforms
  • Fixed a crash on the HL target when pasting non-text data
1 Like

Hi! after updating, I had these errors.



Haxe 4.0.0-rc.3
OpenFL 8.9.4
Lime 7.6.2

1 Like

You need Haxe 4.0.0-rc.4, which added Map.clear().

thanks! i will try it later and post the result here.

Me and at least another user ran into the same issue, link to post below.

It seems to me haxelib should contain stable releases. So in case you ever do an upgrade your projects don’t suddenly stop working. Therefore relying on haxe4rc4 which is not stable seems like a bad idea until haxe is actually stable. (also currently haxe4rc4 breaks the alivepdf haxelib)

Hi,I installed haxe 4.0.0-rc.4. All errors above were gone. Everything worked well when debugging with HTML5 but I had this error with Neko output!

Kill active process…
Called from lime._internal.backend.native.NativeCFFI::$statics line 609
Called from lime.system.CFFI::load line 172
Called from lime.system.CFFI::__loadNekoAPI line 306
Uncaught exception - Could not find NekoAPI interface.

I’m using the Nightly Build of Haxe Develop and all the latest versions of OpenFL, Lime, hxcpp…

What OS and version are you using? Thanks :slight_smile:

I have windows 10 64bit installed on my computer and it is updated regularly!
Haxe 4.0.0-rc.4
OpenFL 8.9.4
Lime 7.6.2
HXCPP 4.0.52
I guess it’s the new 64-bit Neko bugs. It is not fixed completely?

Yep – I ran into this one today and just worked out a fix on dev

After I apply filters (DropShadowFilter and GlowFilter checked) to a TextField it’s position stops to update while changing (x, y) of the parent’s scrollRect on HTML5.

Is that using OpenFL 8.9.5 and Lime 7.6.3?

It seems like with the new update the fps has dropped by some percent… html5 target
true to anybody else?
i donno but the app i’m developing now works slower

This topic is not about versions you specified :slight_smile:

My versions were: 8.9.4 / 7.6.1

Checking on the latest versions (8.9.5 / 7.6.3). Filters not working correctly, too.

It also adds an extra slash to the url of the “pak” libraries, so the game does not work on my cloud hosting.