Neko ends abruptly in debug

This seems to come up pretty often, without being resolved

I’m using run lime build "project.xml" neko -debug -Dfdb
It works fine in release mode /flash debug and I see no evidence that it’s actually hitting an error. I placed trace calls all over and they all fire, an enterFrame event is added but the program ends as soon as the constructor is completed.

PS: Is it known that FRAME_LABEL events are not dispatched in non-flash targets? (tried html5/neko/windows)

I have seen things close on Neko (without a stack trace) if running from certain IDEs (such as FlashDevelop), or sometimes if the error occurs inside of a C++ library (such as the Lime DLL on Windows)

lime test neko -debug from a Command-Prompt or Terminal window may make a difference

No, it does not look like we currently dispatch FRAME_LABEL events, but I can’t imagine it would be hard to add :slight_smile:

1 Like

Tried it, got a stacktrace, apparently the problem was that I called ++ on an uninitialized int in my debug fps tracker. This would have been impossible to track down, so thank you. I created a FlashDevelop issue for this

As for dispatching frame labels in neko, I don’t think it will be very easy, I made a work around, that checks a movieClip’s current frame on an EXIT_FRAME event, and I’m noticing that frame labels seem to be skipped inconsistently.
For instance:

I’m wondering if FrameLabel events were avoided in these targets because animations are not frame based, but rather time based, meaning frames can be skipped.

I think we should look at supporting the event for consistency with the Flash API

Yes, we do skip MovieClip frames (there’s a define to change this behavior), but we do not skip frame actions, so if there is a frame action that stops the clip it will still stop at the correct spot and not skip over it