Lime completion setup failed. But lime works fine?

The full error:
I’ve tried lime setup alot, also reinstalling Lime but there’s always this error.
Also, I think that because of it, there’s another problem: image
And don’t worry, I followed docs to correctly install Lime & Flixel.
I don’t know what to do anymore… ._.

Did you happen to install the lix package manager? I found this similar thread with the error about haxelib run-dir, with a possible solution:

When I try to run haxelib run-dir on my computer, it says that the run-dir command doesn’t exist. I don’t have lix installed on my computer, so I’m guessing that run-dir is a special extra command in lix’s version of the haxelib executable.

Yes, I have global Lix and when I run haxelib run-dir it also says Unknown command run-dir. I tried adding those lines into VS Code settings as shown in that post but it didn’t fix it :frowning:

Based on the fact that you are also getting that run-dir error message, as best I can tell, you seem to have accidentally given precedence to Haxe’s default haxelib executable instead of lix’s special haxelib executable somehow.

Have you tried reinstalling lix? Give it a try. It may give lix’s haxelib executable higher precedence again.

Tried now, haxelib run-dir still doesn’ work :confused:

Have you done anything to change your PATH environment variable recently? It could be that C:\HaxeToolkit\haxe was moved to a more prominent position than the path where lix’s executables are located (I think some kind of global node_modules path, but I could be wrong about that). It may help to change the order around a little bit.

There’s not much else that I can personally suggest. I don’t use lix, and I don’t plan to any time soon. Hopefully, someone more experienced with lix can chime in.