Issue with running OpenFL in Lix

Hello,

I recently decided to start migrating my project to use lix for dependency management. When I try to do:

lix run openfl setup

I get this error:
: haxelib run-dir lime C:\Users\sgalland\AppData\Roaming/haxe/haxe_libraries/lime/7.7.0/haxelib setup -openfl
Failed to invoke haxelib run-dir openfl C:\Users\sgalland\AppData\Roaming/haxe/haxe_libraries/openfl/8.9.6/haxelib setup because Error: Command failed: haxelib run-dir openfl C:\Users\sgalland\AppData\Roaming/haxe/haxe_libraries/openfl/8.9.6/haxelib setup

Has anyone been able to make this work?

Thanks,
Sean

1 Like

Have same issue, trying to find solution

Lix is working as long as you use a global installation. I found no solution with a local installation of lix :frowning: Just install lix and add this to your vscode settings:

"settings": {
	"lime.projectFile": "client.xml",
	"lime.executable": "lix lime",       <------ THIS IS IMPORTANT!
	"files.autoSave": "afterDelay",
	"files.autoSaveDelay": 500,
	"debug.openExplorerOnEnd": true,
}

On the command line, don’t use “lix run openfl”, just “lix openfl”. this worked for me.

If you do a global installation of lix, take note that if you ever decide to remove lix and go back to a regular installation of Haxe, you’ll probably need to do some extra manual cleanup of things that Lix leaves behind. Lix doesn’t restore everything back to its original state when you remove it, and parts of Haxe will be broken until you figure out how to get rid of the rest (even with a fresh installation of Haxe). I might have an easier time if I did it again, but it was a pretty rough mistake that I made when I was a beginner to Haxe.