Illegal instruction in Linux

I installed Ubuntu on an old laptop and now I’m trying to make a Linux version of my game.
It compiles, but when I run the game, I get:

Illegal instruction (core dumped)

I traced it down to the first time music is played (play function):

st = new SoundTransform (1.0);
snd = Assets.getMusic (“assets/music/” + name + “.ogg”);
chn = (0, loop? 10000 : 0, st);

Here is my cpuinfo:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel® Pentium® M processor 1.80GHz
stepping : 8
microcode : 0x20
cpu MHz : 1800.000
cache size : 2048 KB
physical id : 0
siblings : 1
core id : 0
cpu cores : 1
apicid : 0
initial apicid : 0
fdiv_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx bts cpuid est tm2 pti
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds
bogomips : 3591.34
clflush size : 64
cache_alignment : 64
address sizes : 32 bits physical, 32 bits virtual
power management:

Any ideas?

Did you build OpenFL from source or is this the Haxelib release?

If you are building from source, we try to include a number of different development packages in order to support more audio subsystems

I just installed everything from haxelib.
When I disable all music and sound effects, I’m able to get my game to work.

Here are my libraries:

actuate: [1.8.9]
box2d: [1.2.3]
hxcpp: [4.0.19]
layout: [1.2.1]
lime-samples: [7.0.0]
lime: [7.5.0]
openfl-samples: [8.7.0]
openfl: [8.9.1]

Maybe this laptop is too old to be supported, the game runs at 2 or 3 fps.

Is that Neko or C++ performance?

We fallback to software rendering when the OpenGL version seems too old – perhaps that is happening? You can check stage.window.context.type at runtime

For the sound problem, maybe it’s the same problem as Old CPU Regression ?