Can't build with the lime test windows command

I was watching a tutorial on how to build a game to create a mod. It says that to build a game i have to make the command ‘‘lime test windows’’. But it didn’t work because it says that lime is not recognizable as an internal or external command even if i have lime installed. I tried with an other command that is : ‘‘Haxelib run lime test windows’’. But then this message appears : Error: You must have a “project.xml” file or specify another valid project file when using the ‘test’ command.

I don’t know what to do anymore. Can somebody please help me? im new with this kind of stuff.

first run in the command line : haxelib run lime setup it will add lime into your command line so you can do directly lime without haxelib run
Then inside your project folder, run lime test windows. It has to be inside your project folder so lime can find your projec.xml. You can move into the correct folder with cd my/path/to/the/projectFolder or you can directly open the command line from the correct folder (it’s what I always do).
I think you can also run lime test my/path/to/the/projectFolder/project.xml windows.

Thanks for answering!
So i tried what you said, but when i put the command lime or openfl, a message shows saying again that is not recognizable as an internal or external command. They are installed and up to date, but for some reason it doesn’t work.
Later, i tried the command ‘‘haxelib run openfl setup’’ to see if it was something that i forgot. And this error showed up :
Error: Cannot open “C:\Program Files (x86)\haxe\openfl.exe” for writing, do you have correct access permissions?

Any ideas on what i could do?

I recommend uninstalling Haxe, and then reinstalling it to the default location of C:\HaxeToolkit. Normally, openfl.exe and lime.exe are setup in the same folder as haxe.exe. However, Windows puts certain restrictions on C:\Program Files. and C:\Program Files (x86). So it is probably blocking the haxelib run openfl setup command from working properly at this location.

1 Like

Thank you so much! It works now!!! (well it recognizes lime now, but for the lime test windows command there is still an error) :
C:\Program Files (x86)\Funkin-master>lime test windows
Called from ? line 1
Called from CommandLineTools.hx line 1895
Called from CommandLineTools.hx line 22
Called from a C function
Called from CommandLineTools.hx line 126
Called from CommandLineTools.hx line 641
Called from lime/tools/PlatformTarget.hx line 98
Called from WindowsPlatform.hx line 768
Called from hxp/System.hx line 653
Called from /Users/runner/hostedtoolcache/haxe/4.2.1/x64/std/neko/_std/sys/FileSystem.hx line 82
Uncaught exception - [email protected]_create_dir

I had issues while targeting windows. Got it solved here:

You can check if you too might be following wrong steps somewhere.

I saw the discussion, but i think i have a different problem. The command lime works and i have installed visual studios. Now when i put lime test windows, it should build the game just fine, but this new error appears : Uncaught exception - [email protected]_create_dir
What does it mean?

It could be an issue with special characters in the path ? I haven’t checked if this was solved, I’ve had this issue in the past on windows target

It seems to be failing while trying to create a directory.

Remember what I said about C:\Program Files and C:\Program Files (x86)? Generally, Windows doesn’t allow you to modify anything in here. This is probably basically the same issue as with setting up the lime/openfl executables.

I would try putting Funking-master somewhere else where it can actually be modified, like in your Documents directory or something like that.

Ohhh so that was the problem!
It works now, thank you all of you for helping a dummy like me haha
Have a great day!

How do i go inside my project folder and run it?!?!?! IM STARTING TO GIVE UP

The easiest way to run the project is to open the command prompt in the project directory.
You can do it easily from the windows explorer. Move on the project directory.


Type cmd and press ENTER

Now you can type openfl test windows to compile and run.

If you open the command prompt from elsewhere, you will have to type cd path/to/project/directory in the command prompt before openfl test windows. But using the windows explorer is easier.

Ok ill try it!
Also i hope you make Great Mods!

it now says ‘openfl’ is not recognized as an internal or external command,
operable program or batch file.

it just wont work so ive given up.

haxelib run openfl setup should add openfl as a command if I am correct.
But anyway, you can also call all openfl command by adding haxelib run before. For example : haxelib run openfl test windows