Visual Studio Trouble

I installed Visual Studio 2010 Compiler. I can compile for the cpp target without problems. But when I try to compile a small openfl project, it hangs at

  • C:/HaxeToolkit/haxe/lib/hxcpp/3,4,64/src/hx/NoFiles.cpp
  • src/resources.cpp

forever. I tried to use a newer Visual Studio version (2015), but I can not fix the “cl.exe not found” error. It used to work for years, but not this time.

For example I edited the msvc-setup.bat.

I have this folder: C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A with Include, Bin and Lib folders inside.

In msvc-setup.bat there is

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A <----

So I edited it. No Luck, because there is no typeinfo.h in that Include-Folder.

I have

C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC

Folder too, with include, bin and lib folders inside. So I tried that. typeinfo.h is in this include folder.

But now there is no corecrt.h file.

What is that mess? Please help.

I am using Windows 10.

You have to wait it out sometimes, it gets “stuck” there for 20 minutes on occasion. I don’t know what is happening either but it eventually finishes. This is usually while doing the first compile and having lots of assets aggravates the wait.

Hm. I am using haxe together with hxcpp since 2014. It never took that long. I think I waited for 15-20 minutes.

There aren’t any assets in the project. It is just a hello world.

But I will try it again and wait 30minutes … thanks.

I don’t have either of these problems on my Windows machines, using Visual Studio Community, I’m not sure what version, perhaps 2015, not sure.

Does a newer HXCPP help with the resources file? Strange it would take so long :frowning:

I also didn’t usually experience this some versions ago. It just started happening.
Just check the processor usage and you’ll see the compiler churning away during it all.
Usually at a fourth of the total processing power.

I switched back to 2010 and made a clean compile of the hello world openfl project. And it took 28 minutes, but it finished. :wink:

I can’t get 2015 to compile at all. I am using 2015 since ähm 2015, and I never had a problem.

I have a fresh install of Windows 10 and all the haxe libs are the very newest versions.

I wonder if it’s __boot__.cpp that Visual Studio is actually having trouble with, but that compiling on multiple threads shows that __resources__.cpp is also compiling at the same time

__boot__.cpp seems like a more likely culprit for throwing a compiler for a loop

Yes. I asked myself “what is he doing actually?” and checked the cpu usage. He is doing something. But I don’t know what.

Could very well be, also seen that one halting but just a couple of times. Lacking further reference out of memory and don’t usually compile to CPP a lot though. You’re probably on to something as always. :slight_smile: