URLLoader not triggering any events or errors

Hey there,

I have the problem that an older application of mine (written more than half a year ago) does not work any more due to the URLLoader not triggering any events.

This is basically my code:

_loader = new URLLoader(); 
_loader.addEventListener(Event.COMPLETE, completeHandler);
_loader.addEventListener(Event.OPEN, openHandler);
_loader.addEventListener(ProgressEvent.PROGRESS, progressHandler);
_loader.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
_loader.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
_loader.addEventListener(HTTPStatusEvent.HTTP_RESPONSE_STATUS, httpResponseHandler);
_loader.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
_loader.load(new URLRequest("Any VALID URL, nothing works."));

The code is definitely called.

But not a single event is fired. No error, no progress, no success, no crash, nothing. I’ve got nothing to work with, here :smile:

I tried completely removing and reinstalling Haxe & OpenFL, but it just won’t do anything.
I tried under linux as well as under Windows (the program also uses the sys library, so I can’t test Flash), without success.

I just tried compiling with -Dv2, and that makes the program work as expected.

So I am fairly sure we have bug here in the recent OpenFL 3. I’ll report it on the tracker.