URGENT: Cannot do any projects after updating to OpenFl 8.9.6

I use Visual Studio Code for macOS. When I updated OpenFL to 8.9.6, in VSC under Haxe Dependencies it still listed 8.9.5. I removed the older versions using sudo haxelib run clearlibs hoping that would force VSC to recognize 8.9.6. After restating VSC, only haxe (3.4.7) was listed under Haxe Dependencies, no Lime or OpenFl. I verified that both Lime was installed (7.7.0) and OpenFl (8.9.6).

Before when I updated OpenFl, the newly installed version would be used after restarting VSC. I even tried restarting my computer, no difference.

So I reinstalled OpenFl 8.9.5 and VSC recognized that but not Lime 7.7.0. So I installed Lime 7.6.3 and VSC recognized that.

But now when I build a project, I get “Error: Could not process asset libraries (swf)” All my projects use assets stored in swf so now I can’t do anything.

I am using the current version of VSC (1.41.1). Any ideas why VSC won’t recognize Lime 7.7.0 and OpenFl 8.9.6? Why all of a sudden, my swf files can’t be processed.

Can you open a command prompt or terminal and try and do a build from there first?

Make sure these look correct:

haxelib list
haxelib path lime
haxelib path openfl

Then try openfl test using the -verbose flag

Do you use the “swflite” type or the “animate” library type?

Oops I forgot to include the tools.n file in the release

I re-submitted 8.9.6 with the missing file or run lime rebuild openfl

The lime rebuild openfl identified that I needed to reinstall hxp. Did that and then lime rebuild openfl and I was able to build my project.

At first VSC used 8.9.5 but suddenly it showed 8.9.6 and then 8.9.5 then 8.9.6. I’ve restarted VSC a couple times and opened, rebuilt and closed several projects and still have 8.9.6 and lime 7.7.0 so I think that problem is solved.

Thanks

Hey singmajesty, by the way is formatClassName calls in Tools.hx commented on lines 421 and 476 was intended? It was regression for my project in form of some old god-forgotten symbols linked with names like “skins.iconName”. Since we use generate = true, formatClassName was capitalising symbol names, and becouse of haxe requiring capitalised class names all this in summary turns out wrong. That’s not a problem since i just uncomment named strings and rebuild tools, and plan on fix symbol names in the future project updates, but i may be not only one

Here is the original commit:

(Ignore the trace calls that were added)

I think libraries with a prefix value (like <library name="library.swf" prefix="SWF" />) was resulting in double prefixes in some cases (like SWFSWFSymbolName). Perhaps this fixes that issues but still omits capitalization in some cases?

Thanks for re-submitting 8.9.6. Now I can use openfl process again!

1 Like