Unable to read Environment variables in place of classpaths for mcover

I have added below hageflag in xml file for running mcover for my haxe code in openFL. Here MCOVERLIB contains all class paths.

When I run the mcover it is treating ENV variable as string.It is not reading the value.

haxeflag name="–macro" value=“mcover.MCover.coverage([’’], [${MCOVERLIB}], [’’])” if=“flag”

Can any one help me on this ?

I don’t know if the xml file support env variables,

but you could make your own macro calling mcover.MCover.coverage where you’d have access to Sys.environment and Sys.getEnv


This is not supported in the release version of Lime, but it’s something we’ve received a pull request and are checking out. It would be good to support :slight_smile:

It’s in, hold tight for the next build