"Type not found : flash.utils.Object" error after update


I just updated an old config running HaxeFlixel and now when I compile swf target I get :

C:\HaxeToolkit\haxe\lib\openfl/3,6,1/extern/openfl/utils/Object.hx:110: characters 21-39 : Type not found : flash.utils.Object

I get this even with the default template for HaxeFlixel from FlashDevelop (and from the command line too “lime test flash”).

I just reinstalled the last version of Haxe (3.4.0).

My haxelib list :

flixel-ui: 1.0.2 [2.2.0]
flixel: 3.3.6 3.3.10 4.2.0 git [dev:C:\HaxeToolkit\haxe\lib\flixel/git]
haxelib_client: [3.2.0-rc.3]
lime: 2.1.1 2.3.2 2.4.5 [2.9.1] 3.5.2
openfl: 2.2.6 3.0.2 3.1.1 [3.6.1] 4.5.2
swf: 1.7.7 1.8.5 1.8.9 [2.3.1]

The selected versions of Lime and OpenFL are asked by HaxeFlixel.

I searched the forum and tried to understand why this class is missing but cannot find a similar solution. I’ve tried to change the versions in haxelib with no luck (perhaps because this is not a matter of luck ^^)

Do I have to resinstall “all the stuff” from scratch as I find as solution sometimes, or does someone has an advice ? :stuck_out_tongue:


You could try installing Haxe again, sometimes on Windows (I still don’t know why!) Haxe std files disappear

It’s here on Github:

You can check if this file exists in “C:\HaxeToolkit\haxe\std\flash\utils”

Thanks @singmajesty,
I solved the problem by indeed reinstalling all the stack from scratch (HaxeToolkit). I uninstall it in fact…

Previously I looked in the openfl and flash libs and not the std one, and I didnt had the idea to look on the git repo to see where it was missing !

Anyway, thanks for the quick reply :slight_smile:

Please add any extra information (if you have any!) on this issue here :slight_smile: