TextField locks again... this time on Android

Greetings folks.

My current project - an escape game - is working fine on HTML5 and Flash. On Windows it had issues with Lime and OpenFL’s previous versions. There was something wrong with “TextField”. Fortunatelly, that issue was solved.

However, in Android, it seems that problem remains.

I tried Pirate Pig and it works fine - at least it looks ok.

My haxelib list shows:

actuate: [1.8.6]
box2d: [1.2.3]
firetongue: [1.0.0]
haxelib_client: [3.2.0-rc.3]
hxcpp: 3.2.102 3.2.171 [3.2.180]
layout: 1.2.0 [1.2.1]
lime-samples: 2.3.0 2.5.1 [2.6.0]
lime: 2.4.8 2.5.1 2.5.2 2.6.1 2.6.7 [2.6.9]
openfl-ouya: [1.0.2]
openfl-samples: 2.2.2 3.1.0 3.3.0 [3.3.1]
openfl: 3.1.2 3.2.0 3.2.2 3.3.2 3.3.7 [3.3.9]
svg: [1.0.8]
swf: 1.8.9 1.9.1 2.0.1 2.1.0 [2.1.2]
task: [1.0.6]

Thanks for your time

What’s the issue? Crash, or something else? Thanks! :slight_smile:

Crash. I removed all TextField’s and everything is ok.

I made a simple test:


import openfl.display.Sprite;
import openfl.display.Bitmap;
import openfl.text.TextField;
import openfl.text.TextFormat;
import openfl.Assets;

class Main extends Sprite {

private var bg : Bitmap;
private var tf : TextField;
private var f : TextFormat;

public function new () {
    super ();
    bg = new Bitmap(Assets.getBitmapData("img/back2.png"));
    tf = new TextField();
    f = new TextFormat("Arial", 30);
    tf.defaultTextFormat = f;
    tf.text = "Hello World!";
    tf.x = 50;
    tf.y = 150;


The code above just freezes on Android. In the other targets (flash, HTML5 and Windows) it works fine. Any ideas?

I’m hunting this down, I think I may have found where it occurs in Font loading code (if a file is not found), let me see what I find :slight_smile:

Ok, thanks a lot!

In the meantime I’m working on a bitmap-based font system.

This is fixed in Lime and OpenFL on GIT now, and will go out in a release (probably this week)

It was a minor Java problem, and a missing slash to find a default font on some devices

1 Like