SystemPath Compile Exception - Android

Hi, i’m trying to compile simple test app to android target but i’m getting exception:

src/Main.hx:59: characters 26-64 : Unknown identifier : SystemPath

I’ve tried using -Dlegacy but i’m receiving similar exception:

/usr/lib/haxe/lib/openfl/3,0,3/openfl/_legacy/utils/SystemPath.hx:80: characters 41-46 : Unknown identifier : which

I’ve seen there is update on github for the SystemPath class 15 days ago, wondering is it already included in openFl release build ?
Same code works for ios with -Dlegacy!

Same problem here - apparently there is no way to compile for Android with this error going on. This appeared for me with the last haxelib release.

Hopefully easy to fix!

Hey igdeman,

Just solved the problem: which must be changed to inWhich. The problem is only a small typo which has already been solved in the development version.

You can safely make this change in your SystemPath.hx file for a quick solution if you don’t want to switch to dev.

Just did it here and all is working again.

Thanks Tiago_Ling, it works now with -Dlegacy :slight_smile:

Sorry guys, did not realize this fix had not made it out to haxelib yet. Been in process with some big work, but will try and get an update out fairly soon :slight_smile:

1 Like

What’s the alternative to SystemPath if you don’t want to use -DLegacy? I’ve changed the import to openfl._legacy.utils.SystemPath, checked to make sure that actually exists in my haxe directory, but the compiler still throws the same errors.

If you do not use -Dlegacy, use lime.system.System, which has static constants for these paths

Does that include applicationStorageDirectory? It doesn’t seem to have that.

Looks like it’s there: