Swf assets "generate" fails for html5

[ Windows 10 / haxe 3.4 / OpenFL 4.8.1 ]

Try the following :

openfl create nyancat

change project.xml to use generate: <library path="Assets/library.swf" preload="true" generate="true" />

in Main.hx change:

var cat = Assets.getMovieClip ("library:NyanCatAnimation");
var cat = new NyanCatAnimation();

openfl test flash - OK
openfl test windows - OK
openfl test html5 - FAIL : Type not found : NyanCatAnimation

I just tried, it works here.

Is Lime up-to-date? Are your “openfl-samples” up-to-date?

Does your copy use <haxelib name="swf" />, or is it removed (as it should), since SWF is built into OpenFL now?

Hm. There is nothing special here. Using latest version of openfl / lime / samples. Not using “swf” lib-
Just as i wrote i only changed those lines from the original nyancat sample
Same issue for other html5 projects also.
Both flash and windows targets compiles and runs without problems.

This is the testproject, if it’s any help… https://www.dropbox.com/s/523fwxljn1xjarf/nyancat.zip?dl=0

Latest from source, or haxelib?

If source, could you run openfl rebuild tools, then do a clean project build?

Latest from haxelib. I’m in the middle of a project …so i dont want to install dev versions just a the moment…
However; i’m using a Haxe 3.4 build from 25.december : haxe_2016-12-25_development_e08d018.tar.gz …should it matter?

Perhaps you could go under “Export/html5” and look at the “haxe/release.hxml” file, and see if it includes a path to the “_generated” folder.

There should also be an “obj/_generated” folder with “NyanCatAnimation.hx” inside it

Hm. Tried a long time to get this to work… There was no _generated folder or .hx file for the class… Then gave up, went to some other projects, and came back… after rebooting, and cleaning the project suddenly everything was ok. Didnt change anything… strange…