[SOLVED] Permission denied on running HTML5

hello all,

ive had this trouble from the start and its regarding permissions to the folder to run HTML5
this is the error i get both in sublime and terminal

chmod: Unable to change file mode on /usr/lib/haxelib/lime/2,4,0/templates/bin/node/node-mac: Operation not permitted
sh: /usr/lib/haxelib/lime/2,4,0/templates/bin/node/node-mac: Permission denied
lepton:FRONG lepton$ ```

how can i fix this please. its working fine in other builds, though have not tried say, android or whatever, but HTML5 and normal desktop binary is the only one i want to target just now. desktop runs fine also


i also did update to the public release upgrade of lime as well after the fix had worked from the troubles people had had with the latest install

I’m not particularly familiar with mac so hopefully these linux commands works the same in mac.

ls -l /usr/lib/haxelib/lime/2,4,0/templates/bin/node/node-mac
considering the error you most likely aren’t the owner of the file.

It won’t remove the first warning but doing a sudo chmod +x /usr/lib/haxelib/lime/2,4,0/templates/bin/node/node-mac will allow the execution of the web server and launch of your game.

cool spot. ill give that a go and let you know. thanks

it may work, because mac and linux stuff in some ways are the same

hmmmm. tried but no dice. surprised really. its not fully needed right now, which is good. just want to make sure things are working. will keep trying

if anyone else has any ideas, or uses a mac for HAXE/OPENFL, please share :wink:

Yeah, the “node-mac” binary needs to have execution privileges (chmod +x path/to/node-mac) in order to run. Is the web server running when you do a test command?

hi man,

i did get that to work. but then once i stopped it, looked at the code, then tried again. it pops up with this error, which is new. but it did work right when i done the chmod, but after, it then just doesnt start up

thanks for the help

        throw er; // Unhandled 'error' event
Error: listen EADDRINUSE
    at errnoException (net.js:904:11)
    at Server._listen2 (net.js:1042:14)
    at listen (net.js:1064:10)
    at net.js:1146:9
    at dns.js:72:18
    at process._tickCallback (node.js:419:13)
    at Function.Module.runMain (module.js:499:11)
    at startup (node.js:119:16)
    at node.js:906:3
[Finished in 1.9s with exit code 1]
[cmd: ['haxelib', 'run', 'openfl', 'test', 'project.xml', 'html5', '-debug']]
[dir: /Users/lepton/Developer/HAXE/GAMES/FRONG]
[path: /usr/bin:/bin:/usr/sbin:/sbin]

Oh, that means that the server is already running (another window?)

You can try openfl test html5 --port=3001 to launch the server on a new port, or hunt down the old window and Ctrl+C it to stop the web server process

aye that works. thanks a bunch. so how can they be hunted down to stop the processes then? im more than sure i will need it if i stop and start :wink:

i would have thought that if you close the window, that would close the port? would this be done through terminal, or can be done through sublime? i guess

many thanks. again. the newest update to lime works a treat :wink:

On a Mac or Linux, I usually use Sublime with a separate terminal window open to build. This is because Sublime’s shortcuts to build are based on the file that is open – if you are updating library code that is not inside your project (like I am constantly) then it does not know how to build – this is different than FlashDevelop, which has true project files, so you can always build the same project no matter what file is open

In this scenario, I run openfl test html5 and it keeps running – it has the webserver going. If I Ctrl+C to kill the process and openfl test html5 again it should work

awesome. fantastic. thank you very much. ill keep that in mind. i wish flash develop did work for mac now :wink: