[SOLVED] Neko not working? Solution: Turn off virus scanner!

Neko should be working out of the box, right?
But when I try to compile as neko flashdevelop says “Build succeeded”, but the app does not start.
Any hint?

Yes it should.

If you do openfl test neko manually in a terminal does-it open?

Error: The command “openfl” is either misspelled or was not found . (translated from german)

Is there a specific directory where to run that command? I tried several, none worked.

try haxelib run openfl test neko

Ok thx, why does just “openfl test neko” not work for me?

I must say I reinstalled Haxe and Neko and now I get this error:
cmd: "C:\HaxeToolkit\haxe/haxelib" run lime build "project.xml" neko -release -Dfdb Called from ? line 1 Called from CommandLineTools.hx line 1385 Called from CommandLineTools.hx line 25 Called from CommandLineTools.hx line 126 Called from CommandLineTools.hx line 604 Called from lime/project/PlatformTarget.hx line 77 Called from lime/tools/platforms/WindowsPlatform.hx line 122 Called from lime/tools/helpers/NekoHelper.hx line 40 Called from /usr/lib/haxe/std/neko/_std/sys/io/File.hx line 54 Uncaught exception - [file_open,bin/windows/neko/bin/Test.exe] Build halted with errors. Done(1)

To use the openfl command you need to install it with openfl setup.

The error is because the file is already open, is there a window with your game that wasn’t closed?

you mean “haxelib run openfl setup” :wink:
cool that worked, thanks!

Ok, seems you are right, now the error is gone, I get this, but no neko window or whatever opens?

Build succeeded
haxelib run lime run "project.xml" neko -release
Running process: C:\HaxeToolkit\haxe\haxelib.exe run lime run "project.xml" neko -release

When i do

  openfl test neko

also notthing happens, no error and nothing. It seems like everything is working, but the neko window is invisible or something?!

Do you have Neko installed correctly? Try typing “neko” into Command Prompt; it should print the version number and give you a usage message.

I just installed it, seems allright

NekoVM 2.0.0 (c)2005-2013 Haxe Foundation
  Usage : neko <file>

Check the Export/windows/neko/bin folder. Does it have an executable file for your app?

yep, the .exe is there.
I also see the exe in my task-manager.
So it makes sense that I cannot compile for neko again (Uncaught exception - [file_open,bin/windows/neko/bin/Test.exe])
It seems it is running, but invisible.
I also cannot stop the process in the task manager.

You can’t even stop the process? Very odd.

Maybe it’s waiting for a response. Try minimizing windows one at a time, because there might be an error message buried somewhere there. (It’s possible for this to happen without anything showing up in the taskbar, which is why you have to minimize your windows by hand.)

Otherwise, just restart your computer and try again.

Tried again, there are three Test.exe in the TaskManager.
Two neko.exe in the Taskmanager
No Error Message anywhere.
When I try to stop any Test.exe, nothing happens, also no error message.
The neko.exes can be stopped.

UPDATE: When trying to release for windows, the same happens … Build succeeded, Test.exe shows up three times in taskmanager, but no window, nothing to see

Could you try a sample?

openfl create DisplayingABitmap
cd DisplayingABitmap
openfl test neko

See if it works?


Already tried another sample. Tried DisplayingABitmap now again, still nothing showing up at all :frowning:

Could this be because something else on my system is broken … I have no idea where to start finding the problem. The installation must be ok, as I even reinstalled haxe and neko.

Update: By testing it on a laptop I finally found out that the reason is my virus scanner “Avast”.
Thank you all!