[SOLVED] Mac - "no member blit" (native) "Primitive not found" (neko)

I’m on Mac OSX 10.10 Yosemite. When I try to build a demo for neko, I get the following error:

Called from flash/display/BitmapData.hx line 753
Called from flash/Lib.hx line 191
Called from /usr/lib/haxe/std/neko/Lib.hx line 30
Uncaught exception - load.c(357) : Primitive not found : ./[email protected]_bitmap_data_set_flags(1)

When I try to build for Mac native, I get:

xcrun --sdk macosx10.9 clang -Iinclude -c -fvisibility=hidden -O2 -I/usr/lib/haxe/lib/hxlibc/1,1,4/include -DHX_MACOS -m64 -Wno-parentheses -Wno-null-dereference -Wno-unused-value -Wno-format-extra-args -Wno-bool-conversion -DHXCPP_M64 -DHXCPP_VISIT_ALLOCS -x c++ -frtti -Iobj/darwin64//__pch/haxe ./src/sys/io/Process.cpp -oobj/darwin64//src/sys/io/Process.o
./src/haxe/io/Bytes.cpp:55:12: error: no member named 'blit' in
      'Array_obj<unsigned char>'
                this->b->blit(pos,src->b,srcpos,len);
                ~~~~~~~  ^

I had previously been able to build for Neko and Android (prior to Yosemite) but am now having this problem. Any ideas? I’m using OpenFL 1.2.3, Lime 0.9.7, OpenFL-native 1.2.3, and hxlibc 1.1.4.

UPDATE: This was fixed by upgrading to OpenFL 1.4, although I don’t see why 1.2.3 shouldn’t be able to build. I also tried uninstalling and reinstalling Haxe, but that had no effect. Thanks!