[Solved] iOS build problem (OpenFL 2.2.4 and Lime 2.0.0)

Hi guys!

I’m having some issues when trying to build a sample project for iOS.
This is the error message:

Error: Source path “/usr/lib/haxe/lib/lime/2,0,0/ndll/IPhone/liblime.iphoneos.a” does not exist

I checked at that folder and there’s no liblime.* file, just these other libraries: libcurl, libcurl_ssl, libfreetype, libjpeg, libogg, libpng, libvorbis, libz.
I tried building lime (running lime rebuild ios and lime rebuild mac) but there’s no change on the exported libraries.

The sample project was created using this command: lime create project:openfl test

Do you have any idea about this?

This is a full list of the versions of my libraries:
actuate: [1.8.4]
box2d: [1.2.3]
hxcpp: [3.2.37]
layout: [1.2.0]
lime-samples: [2.3.0]
lime-tools: [1.5.7]
lime: [2.0.0]
openfl-samples: [2.2.2]
openfl: [2.2.4]
spritesheet: [1.2.0]
swf: [1.8.6]

Thanks in advance :slight_smile:

You aren’t using the latest lime, 2.3.3, I’d advice you to check with this one.

Also for information, it looks like you are using a haxelib version of lime, these do not support the rebuild command, only the github version.

Hi iblion, thanks for answering.
I need to use Lime 2.0.0 for this specific project (I’m trying to do a build of an old project, but at first I need to be sure about my build settings with a hello world at least).

Do you know where can I find any guide to build lime manually?

Thanks again.

You can find the repository here: https://github.com/openfl/lime
There’s a 2.0.0 tag: https://github.com/openfl/lime/tree/2.0.0 (git checkout 2.0.0)

Indications on how to use the dev version https://github.com/openfl/lime/tree/2.0.0#building-from-source

Be sure to clone recursively, git clone --recursive, otherwise you’ll be missing some files.

Thanks for your help, I found that the problem was with the example project, I just fixed it and everything works fine now.