[SOLVED] Invalid field access : split during haxelib run openfl setup

Hello, I’m trying to install openfl on linux 64 bit machine. But I’ve got the following exception:

[email protected]:~$ haxelib run openfl setup
Called from ? line 1
Called from RunScript.hx line 40
Called from helpers/PathHelper.hx line 197
Uncaught exception - Invalid field access : split

The same exception is occurred with haxelib run lime setup.

I have haxe 3.1.3, haxelib 3.1.0-rc.4 and here is the list with my haxelibs:

[email protected]:~$ haxelib list
format: [3.1.2]
hxcpp: [3.1.68]
lime-tools: [1.5.7]
lime: [2.1.3]
openfl: [2.2.8]
svg: [1.0.8]

As I understand the issue correctly, haxelib just cannot access to standard String function split. But why? I have HAXE_STD_PATH pointed to haxe std folder, and I have String class there with split method. What am I doing wrong? Can someone help me with this issue?

Could you please try running haxelib path lime, and see what it returns? Also, do you have $HAXEPATH set? (you should not have to, quite the reverse, perhaps it is set and messing things up)

2 Likes

You my hero! The reason was that I had HAXEPATH variable set. Thank you very much.

Hi there, having the same issue even though I don’t have $HAXEPATH set. I’m on a Mac and installed Haxe from homebrew in case that makes a difference.

This is my first contact with Haxe so any help as to how to troubleshoot/debug would be appreciated.

Could you try installing using the standard Haxe installer?

Hi. Sorry for bumping an old thread, but I’m facing exactly the same issue except that my HAXEPATH is not set. What did you set the HAXEPATH to? (Or rather what should it be set to?)

@jordgubben Is your haxelib correctly configured? => does haxelib config returns the correct path?

What version of lime and haxe do you have?

The HAXEPATH variable shouldn’t be needed in most cases.

Haxe 3.2.0, Lime 2.5.2, No HAXEPATH, haxelib uses /opt/local/lib/haxe/ (I have also tried using /opt/haxelib/)

DeLorean:~ jakob$ haxe -version
3.2.0    
DeLorean:~ jakob$ haxelib config
/usr/local/lib/haxelib/
DeLorean:~ jakob$ echo $HAXEPATH

DeLorean:~ jakob$ haxelib list
lime: [2.5.2]
openfl: [3.2.2]

I’m also having a similar issue with lime.

DeLorean:~ jakob$ haxelib run lime setup
Called from lime/system/System.hx line 553
Called from lime/system/System.hx line 304
Called from lime/system/System.hx line 414
Called from lime/system/System.hx line 239
Called from /usr/lib/haxe/std/neko/Lib.hx line 30
Uncaught exception - load.c(237) : Failed to load library : lime.ndll (dlopen(lime.ndll, 1): image not found)

Don’t know if it’s related. But the path to Lib.hx is wrong.

Oh you have completely different error.

lime.ndll seems missing, strange, does /usr/local/lib/haxelib/lime/2,5,2/ndll/Linux/lime.ndll exists? (or the Linux64 folder depending on the architecture you have)

Could you try removing and reinstalling lime?

I have uninstalled and reinstalled lime. Does not appear to help.

I have a bunch of lime.ndll files:

DeLorean:~ jakob$ find /usr/local/lib/haxelib/lime/2,5,2/ndll -name lime.ndll
/usr/local/lib/haxelib/lime/2,5,2/ndll/Linux/lime.ndll
/usr/local/lib/haxelib/lime/2,5,2/ndll/Linux64/lime.ndll
/usr/local/lib/haxelib/lime/2,5,2/ndll/Mac/lime.ndll
/usr/local/lib/haxelib/lime/2,5,2/ndll/Mac64/lime.ndll
/usr/local/lib/haxelib/lime/2,5,2/ndll/Windows/lime.ndll

(Also I’m on OS X, not linux, if that helps)

What does haxelib path lime give you?

I have same split error with different line.
Same error with haxelib run openfl setup…

[email protected]:~/Project/lisp/game_engine$ haxelib run lime setup
Called from ? line 1
Called from CommandLineTools.hx line 1400
Called from CommandLineTools.hx line 25
Called from a C function
Called from CommandLineTools.hx line 61
Called from lime/tools/helpers/PathHelper.hx line 202
Uncaught exception - Invalid field access : split

Here is haxelib path lime.

[email protected]:~/Project/lisp/game_engine$ haxelib path lime
-L lime/2,9,0/ndll/
/home/kappa/haxelib/lime/2,9,0/
-D lime

My HAXPATH is not set and I do not know what to do.
Any suggestions??

Here are some more information if it helps…

[email protected]:~/Project/lisp/game_engine$ haxe -version
3.0.0
[email protected]:~/Project/lisp/game_engine$ haxelib config
/home/kappa/haxelib/
[email protected]:~/Project/lisp/game_engine$ haxelib list
hx-yaml: git [dev:/home/kappa/haxelib/hx-yaml/git/src]
openfl: [3.6.0]
lime: [2.9.0]

Thank you in advance

Could you try upgrading to the latest Haxe and haxelib releases? I think you’ll need Haxe 3.2 to use Lime