[SOLVED] First compilation with Android

Hi everyone. I’m trying to advance in several aspects of the tool. One of these is to create Native applications. The first step I tried was to compile “HandlingMouseEvents” project, with no luck. I followed all the instructions to install SDK, NDK, Ant and JDK but when I try to compile stops with this message:

C:\Development\Android SDK\tools\ant\build.xml:892: The following error occurred while executing this line:
C:\Development\Android SDK\tools\ant\build.xml:894: The following error occurred while executing this line:
C:\Development\Android SDK\tools\ant\build.xml:906: The following error occurred while executing this line:
C:\Development\Android SDK\tools\ant\build.xml:283: null returned: 1

Total time: 6 seconds
Build succeeded
haxelib run lime run “project.xml” android -debug
Running process: C:\HaxeToolkit\haxe\haxelib.exe run lime run “project.xml” android -debug
can’t find ‘C:\HaxeToolkit\haxe\lib\openfl-samples\2,2,2\HandlingMouseEvents\Export\android/bin/bin/HandlingMouseEvents-debug.apk’ to install

Honestly I don’t have any experience on Mobile devices …So any help would be greatly appreciated


I know it says “the following error occurred,” but the error message is actually above the “BUILD FAILED” line.

Thanks for the quick response.

That is the first line in the output window. All the compilation messages seems to dissapear. I tried Pausing the output and this is the best I have


[javac] Compiling 6 source files to C:\HaxeToolkit\haxe\lib\openfl-samples\2,2,2\HandlingMouseEvents\Export\android\bin\bin\classes
[javac] Note: Some input files use or override a deprecated API.
[javac] Note: Recompile with -Xlint:deprecation for details.



[dex] input: C:\HaxeToolkit\haxe\lib\openfl-samples\2,2,2\HandlingMouseEvents\Export\android\bin\bin\classes
[dex] input: C:\HaxeToolkit\haxe\lib\openfl-samples\2,2,2\HandlingMouseEvents\Export\android\bin\deps\extension-api\bin\classes.jar
[dex] Pre-Dexing C:\HaxeToolkit\haxe\lib\openfl-samples\2,2,2\HandlingMouseEvents\Export\android\bin\deps\extension-api\bin\classes.jar -> classes-78c2f91db6c6d1a439cd773ff7462757.jar
[dx] unknown output extension: C:\HaxeToolkit\haxe\lib\openfl-samples\2
[dx] usage:
[dx] dx --dex [–debug] [–verbose] [–positions=] [–no-locals]
[dx] [–no-optimize] [–statistics] [–[no-]optimize-list=] [–no-strict]
[dx] [–keep-classes] [–output=] [–dump-to=] [–dump-width=]

[dx] dx --help
[dx] Print this message.

Could be an issue with the worlking dir?

Best regards

FlashDevelop sometimes does clear the log at inconvenient times. Try compiling from the command line instead. (Open Command Prompt, navigate to your project folder, and type “lime test android”.)

Yes the problem was with the folder filename. Seems like Dex does not like “,” in the 2,2,2 of the folder. I created a new project. I’ve added a com.firsttest in the package name and it worked!!!

Anyway… Maybe my posts seems to be trivial but I hope it will help to “flash ide” prorgammers with no experience in command line, packages,etc,etc,etc

Thanks again for the help

You’re supposed to make a copy of the sample projects before running them. Did you find a tutorial that doesn’t mention this?

Oh, and on this topic, try “openfl create HandlingMouseEvents” to generate a copy of the sample elsewhere, where Android won’t get upset by it :slight_smile: