[Solved] Broken my setup, now Java compile error (Android)

Hi there,

I was able to setup and write a simple game on Ubuntu 14.04 (https://github.com/DeKugelschieber/BreakoutsFL). But somehow I have now broken my setup while installing/reinstalling lime for my next project…
OpenFL builds the Android project and starts compiling. But it fails build with the following output:

[javac] Compiling 6 source files to /home/marvin/Projekte/planety/export/android/bin/bin/classes
[javac] /home/marvin/Projekte/planety/export/android/bin/src/org/haxe/lime/MainView.java:711: cannot find symbol
[javac] symbol : variable Sound
[javac] location: class org.haxe.lime.MainView.Renderer
[javac] Sound.checkSoundCompletion ();
[javac] ^
[javac] Note: Some input files use or override a deprecated API.
[javac] Note: Recompile with -Xlint:deprecation for details.
[javac] 1 error

Is there some way to fix it? I tried reinstalling everthing, but that haven’t changed anything.
How can it not find the Sound class?


It looks like it will be fixed soon: https://github.com/openfl/lime/issues/404

Okay it’s a bug. Good to now.
I got it working again by restarting and deleting the export folder. Strange.

For information, I had a lot of issues with OpenFL 3.0.1 and Lime 2.3.1. To solve it I downloaded the development version of lime (https://github.com/openfl/lime/archive/master.zip) and installed it with haxelib local zipfile.
Also, don’t forget to use -Dlegacy when compiling.

1 Like

I’m releasing an update today, sorry for the trouble! :slight_smile: