Setup android failure on Linux 64 bit

Hey there, I’m having issues configuring android on openfl.
OS: Ubuntu 14.04 LTS 64-bit
version: (3.0.3-LNyxj2)

Here’s the command I’m running:

sudo openfl setup android

The error:

cp: cannot stat ‘android-sdk-linux/*’: No such file or directory
Uncaught exception - Error running: cp -R android-sdk-linux/* /opt/android-sdk []

Running this command seperately gives the same error, because of the asterisk which is a mistake.

The suggested solution is to change the command to:

 cp -R android-sdk-linux/. /opt/android-sdk

where the “*” is replaced with a “.”

This can be circumvented by manually copying the files and skipping the sdk in the installation but it would be nice if the installer didn’t break on this.

The NDK installation and apache ant have the same error:

Uncaught exception - Error running: cp -R android-ndk-r8b/* /opt/android-ndk []
Uncaught exception - Error running: cp -R apache-ant-1.9.2/* /opt/apache-ant []

Okay, I think this might do it :slight_smile: