Setting up Openfl and hxcpp

So, it’s been a while since i last used openfl and because i’m regaining interest i tried to set up everything. The flash output works fine but trying to install hxcpp just downloads nothing and says its done. I don’t really know if i’m doing something wrong. Does anybody have any suggestions?

Try typing haxelib path hxcpp on the command line. If it prints a folder, check that folder to see what’s there.

If there’s nothing, type haxelib config to get the folder where Haxelib installs things, and check if there’s a partially-downloaded zip file in there. If so, delete it and try again.

Thanks for the suggestion.
Tried it but there’s nothing in the lib folder. The command prompt outputs this message.

Downloading hxcpp-3,2, Download complete : 0 bytes in 0s (0KB/s)

I don’t know if it’s something with my install. I tried it on another computer but still had the same results. I noticed that openfl.exe and lime.exe didn’t get placed in the haxe folder. But you can still acces via haxelib run. Don’t think that should be a problem. (Change between versions?)

Nothing at all in the lib folder, or no half-finished zip files? If there’s nothing at all, then there’s something wrong with your Haxelib install. But since you mentioned you can access OpenFL and Lime using haxelib run, I’ll assume it’s just the zip file.

You might want to try reinstalling, but there’s also the option of downloading the zip manually. Once it’s downloaded, install it with haxelib local path/to/hxcpp-3,2,

For some odd reason i’m not able to connect to the download page.,2,

Can you download an older version? (I’m not saying you have to use the older version, I just want to figure out where exactly the problem is.)

Or what if you added a “cache buster” to the end of the download url, like this?

I’m able to download till version 3.2.37 and then the versions page shows me that there are 0 downloads for all versions after. Cache buster doesn’t work either.

EDIT: Apparenty avast blocked the pages. Weird. But it works now! Thank you.

I see “0 downloads” too, so it’s unrelated to Avast. But in any case, glad you got this figured out!

I read somewhere there’s an issue with haxelib’s site showing 0 downloads when it shouldn’t.