Segmentation fault at compiling on linux

first time trying to compile for linux, and i’m getting:

 Segmentation fault

Yes, only that. i tried lime build, openfl test, openfl build, with -Ddebug and -Dlegacy (even if is legacy on the application.xml) and i could not get any extra output.

installed haxe from the deb package (3.2.1) and i have OpenFL 3.6.1 and Lime 2.9.1.

Any idea what i could do to have a more verbose output?

<haxedef name="HXCPP_CHECK_POINTER" />
<haxedef name="HXCPP_STACK_LINE" />

More info here.

unfortunately, that didn’t help.

with -verbose i get:

Initializing project...
Using project file: /home/shadowlap/ownCloud/games/hacknblocks/hacknblocks/application.xml
Reading HXCPP config: /home/shadowlap/.hxcpp_config.xml
Using target platform: LINUX

Running command: UPDATE
Segmentation fault

i suppose this is a problem in the lime installation itself? i already run openfl setup linux and has installed everything that was missing, with the same result at compiling.

i have the same problem, it doesn’t compile for any platform, i tried flash, neko and i only get “Segmentation Fault”, i am on linux mint 17.1

lime 2.9.1:
Neko tells me *** … free(): invalid pointer: … ***
Linux (cpp) just segfaults without help.
Html5 and Flash targets work.

Going back to lime 2.9.0 seems to work for me.

tried lime 2.9.0 and openfl 3.6.0. didn’t work, same result

with lime 2.4.4 and openfl 3.1.0 the version i use when something goes wrong, i get:

 Called from lime/utils/ByteArray.hx line 110
 Called from lime/system/System.hx line 304
 Called from lime/system/System.hx line 419
 Uncaught exception - Segmentation fault

same as in this link:

btw, neko commands work, is 2.0. already run openfl setup linux too, all packages installed.

For lime 2.4 you probably need haxe 3.1.

My working combination at the moment is Haxe 3.2.1/Lime 2.9.0/OpenFL 3.6.1.

Sometimes it’s some old cache. You could try to delete your /usr/lib/haxe/std directory and install again.
And maybe use instead of deb.

i’m currently using haxe 3.2.1 with llme 2.4.4 on windows with no problems at all.

tried to uninstall the deb, clean the std folder, and reinstall again from the deb, same result.

i’ll try that standalone installer to see if it works (btw, that link is broken)

ok. got it working with the installer, link is fine, i couldn’t open it with mint 16, with archive app. needed to be extracted with tar command.

Just had the same problem. Updating haxe to 3.2.1 did the trick, thank you so much!

I am experiencing a similar problem presently. Trying to run neko versions will segfault, and trying to build html5 versions will segfault. This seems to be a lime issue.

I posted to openfl’s github issues, here is the link

I’ve been trying different versions with little success.

I responded on Github, this might be a Haxe installation issue