Restart Completion server each time

Running Completion server as haxe -v --wait 6000 I noticed that macros will be recognized by the compiler for the first compilation only, then, I will start getting errors as Type not found for any type that was defined into a macro

Would would compilerflag works only the first compilation after starting Completion server?

<compilerflag name="--macro Init.init()" />

If I compile without connecting to completion server, it will successfully build the project, however,I am loosing caching benefits to speed up building.

Any idea ?

If you use VSCode with the Haxe plugin, it includes its own completion server. Perhaps that would behave differently?

I think that it’s a known issue with Haxe that certain types of macros don’t work well when running the completion server. Unfortunately, I don’t recall the exact details.

I’ve set haxe to 4.2.5 and I see the problem is gone, and yes @Confidant with haxe plugin, I am now able to build with option --connect 6000 but still, building time is not fast:

real    0m19.138s
user    0m14.432s
sys     0m2.118s

any hint on speeding up project building ?

It is beyond my expertise now, ha ha.