Rendering problems using Tilemap

Test on older android phone (galaxy s4 mini) is not rendering Tilemap correctly. Has anyone had the same issue?

I tried simplest Tilemapexperiment using this tutorial:

and with same result and same rendering problem.

Does BunnyMark work? Have you tried in HTML5, or on your desktop, or other devices, do they work?

It works on other deveices and html5. I have this problem only on 1 of my test devices.

Hmm, this seems like an odd graphics driver issue. Do you (by chance) have a guess what graphics card your device has? It looks like they released this model with two, depending on where it was sold:

It seems it has Adreno 305 gpu.

Same problem with bunnymark.

What version of OpenFL are you using? Did this used to work?

Does it maybe have a dependency on OpenGL ES 3.1, which is only supported by Android 5.0?

openfl version 7.0.0

I haven’t tested on this phone before, so i don’t know if it used to work.

We use OpenGL ES 2.0 on Android devices, to my knowledge.

We made changes to Tilemap in OpenFL 6.0.0, it might be possible to test that release, or the release before, to see if either behaves differently on this device?

Found a Galaxy S4, and it has some funny rendering as well. I’ll try and test it soon, and hopefully it will sort out what’s going on

1 Like

Okay, just committed a fix that resolved the rendering issues on the Galaxy S4 locally, here. The Adreno GPU didn’t like passing mat4 or vec4 array types as attributes

1 Like