Raspberry Pi 2 anyone?


@gepatto same thing testing AddingAnimation with openfl


Strange, Let me try and rebuild again myself…

I see there’s an upgrade to openfl (now on version 5.1.3).
So you will need to run:
openfl upgrade
haxelib update


ok updated to latest lime and openfl . do i have to rebuild ?


I just:

cloned the current commit from the lime GitHub repository.

git clone --recursive https://github.com/openfl/lime

rebuild lime

lime rebuild lime linux -rpi

updated all haxelib modules

haxelib update

checked version with haxelib list

lime: 5.1.0 [dev:/home/pi/Development/haxe/dev/lime]
openfl: 5.1.2 [5.1.3]

and build and openfl-sample with:

openfl test linux

This works for me and I have it running from the command line.

It’s a bit tricky that lime for raspberry pi can only be built manually like this,
and you have to keep the versions of openfl and lime in sync.
They don’t have the same version number and that makes it a bit difficult.

Still it’s strange that the install script doesn’t work properly because that’s version independent.
And I have used it for many sd-cards without problems.


@gepatto Yay ! i got it running ! i’ve been stuck with boot/config.txt and swapping gldrivers which have gave me some reboot errors but finally got it ! thx ! you got it right i had to get lime from github. don’t know why your gist made a wrong install though.
thx again !


You’re welcome.

I think the gldrivers might have been the real problem.
But I’m glad it’s working now!

Have Fun!


indeed ! gl drivers are not stable at all. i cannot get samples running when they are activated. So it makes it useseless. When unactivated , piratePig freezes. Aside of it on e time on 2 my menu bar disapear.


how did you fix g++: error: ./hxcpp/git/lib/Linux64/liblinuxcompat.a: No such file or directory ?


Try lime rebuild hxcpp linux -static


@sbimikesmullin If you keep getting the linux64 errors, try setting a variable:
<set name="rpi" value="1"/>
in your . hxcpp_config.xml file in your homedirectory, like I’m doing in my setup script here: https://gist.github.com/gepatto/d2248ae0f649d525667f33a4e4e21ca5#file-install_haxe_rpi-sh-L79

and then rebuild lime with
lime rebuild hxcpp linux -static
like Joshua is saying.


Hi. I fired up my RPi 2 B recently and decided to give OpenFL another go as it’s been a while and this thread shows some promise. :slight_smile: But I had problems… It’s a Jessie based image I’m using so there isn’t any 64bit errors as recently mentioned in this thread.

I ran the install script from the gist above (very comprehensive btw - nice job @gepatto) but unfortunately with the latest OpenFL/Lime from git, I get an error during the lime rebuild tools linux -rpi -v step.

Here’s the error … trying to g++ OpenGLBindings.cpp

In file included from ./src/graphics/opengl/OpenGLBindings.cpp:5:0:
./src/graphics/opengl/OpenGL.h:17:23: fatal error: GLES3/gl3.h: No such file or directory
#include <GLES3/gl3.h>

I tried to comment out the GLES3 stuff in the #elif defined (EMSCRIPTEN) || defined (RASPBERRYPI) in Lime/project/src/graphics/opengl/OpenGl.h but that lead to other errors that seemed a bit tricker than just commenting things out :wink:

Any ideas would be greatly appreciated. Thanks in advance.


You’re almost there,

You have run into a small know bug in the latest commit.
|| defined (RASPBERRYPI)
in lime/project/src/graphics/opengl/OpenGL.h.cpp is just in the wrong place.
change line 5 to
#if defined (ANDROID) || defined (RASPBERRYPI)
and change line 13 to
#elif defined (EMSCRIPTEN)


Building as we speak… Fingers crossed. Certainly getting further than before :slight_smile:



@Greg209 Drumroll please …


lime rebuild tools linux -rpi -v … Success…Yay!!!
lime rebuild lime linux -rpi -v … Progressing but taking agggggeeeessssss


@Greg209 Yes compiling lime (the first time) is very slow on a Pi.
that’s why I enabled compilercache in the setup script,
so that when openfl is working and you started on your own project it doesn’t compile everything everytime

If compiling succeeds, just remember that on the Pi openFL does NOT run in a window.
So always add a keyboard eventlistener to the stage and listen for a key or keycombo and then call
in your project, otherwise there is no clean way to exit your app.


Yeah - saw you comments before and now building your DisplayingABitmap. All looking good so far :slight_smile:


And I Just made a pull request , and it got merged within a 2 minutes :smiley: :+1:
So now anyone should be able to just clone the repo again.


Hey guys,

Hopefully this should help:


I Like it!
Maybe some might argue that they need the escape key for other purposes.
But I don’t think there will be many :wink:

Thnx Joshua