[PWYW/0-minimum, win/linux] Willy and Mathilda's Houseboat Adventure: The Game

Hi everyone!

I’m “nervouscited” to make available an early paid preview version of #mathildagame, developed with HaxeFlixel/OpenFL!

You can find it with the itch.io app or at https://ibwwg.itch.io/mathildagame …have fun!

Made with love from
IBwWG

1 Like

A few updates later, Beta 10 is out! Also, the early access version is on sale (90% off!) only for a few more days! :slight_smile:

OK, the whole thing is now PWYW without a minimum, so please try it out!

I managed to build the game for Linux last night, with very few changes! Which means there’s probably a bug or two at runtime. :slight_smile: If you have Linux please give it a go and let us know!

It comes in two flavours. You probably want the normal one unless you have a very old video card like our netbook does, in which case you probably want the “opengl 1.4 compatible”, software-only one.

Both Linux versions (on Ubuntu 15.10):

./mathildagame
Called from systools.Loader::load systools/Loader.hx line 20
Called from cpp.Lib::load /usr/lib/haxe/std/cpp/Lib.hx line 34
Error : Could not load module [email protected]_init__0

1 Like

@MiltonW Thanks very much for testing, is that right at the beginning, or from trying to save/load an image in Painting Your Dreams? I had found that in the latter, but it’s really unfortunate if it’s blocking you from playing the game at all.

Right at the beginning.

OK, thanks. I’ll look into it, but it may honestly be a few weeks, since I’m on the road without a Linux computer at the moment. I didn’t find much around, but if I get a chance to nab a USB stick I’ll see if I can get that version of Ubuntu on it and find out if I can reproduce it. Meanwhile I’ll see if the library author can help.

Actually you know what, now that I think of it, a tester under Windows reported the same thing, and I was puzzled then too because it had worked on my machine OK. I think somehow the build process didn’t copy all the needed files over. I had fixed it already, but maybe each platform needs an adjustment. Dang! And thanks again!

Maybe the library needs an include.xml and an ndll tag?

That’s what’s a bit confusing: I already added a haxelib and ndll tag to the project.xml to get it to work on windows. (Doesn’t include.xml just feed more ‘project.xml’ parameters into it?)

Yep, but it does so automatically when a user includes the haxelib. Effectively (for you) its the same, but for a library author, it means end users aren’t faced with this problem of not having files they need

Ah, brilliant! Yes, that’d be a welcome addition. Any idea why it would work under Windows that way, but not under Linux? Or is it maybe that I compiled on a 32-bit Linux box so it doesn’t look in the right place for 64-bit?

@MiltonW that question assumed you’re on a 64-bit machine, is that true? :slight_smile:

@GimmickyApps Of course :slight_smile:

Heh, not necessarily :wink: I compiled on a 32-bit machine. So maybe that is it. But I’m surprised it’s not forward-compatible…?

If the ndll is linked against 32 bits libraries that a 64 bits os don’t have it could lead to such an error I think,

@MiltonW I’m guessing there’s a systools.ndll next to the executable,
could you do a ldd systools.ndll?

libgconf-2.so.4 => not found

locate libgconf
/usr/lib/x86_64-linux-gnu/libgconf-2.so.4

@ibilon, OK so the 64-bit OSes don’t necessarily include the 32-bit libs?

MiltonW’s error doesn’t make sense to me, why is it not found, if locate can locate it?

Not necessarily, at the extreme 64 bits linux can’t run 32 bits exe.

Even in more normal situations a lot of 32 bits libraries are missing because the os doesn’t need them and therefor doesn’t install them.

It doesn’t, that’s a 64 bits library: “x86_64”

I will have to set up a 64-bit Linux machine at some point. Sorry for the delay, I am on dying low-end hardware without even a spare USB key. I should go invest in one so I can at least compile on something. :slight_smile: (Unless there’s a good free way to do virtualization under Win7SP1 Home Premium?)

Meanwhile the 32-bit Linux builds as well as the Windows build are now at the 14th beta release, 0.2.4, and there are also “bleeding edge” builds that are less tested but have the latest of whatever I worked on that day. https://ibwwg.itch.io/mathildagame