Problem show displayObject from SWF library

Hello again have a problem with display children from swf asset.
I have a shape in movieclip filled with bitmap fill in Flash CS6, some shape fills shown fine, some have some issue can’t figure out

whats the porblem? am I doing wrong?


<?xml version="1.0" encoding="utf-8"?>
	<meta title="m2_port_HTML5" package="m2portHTML5" version="1.0.0" company="Real Estate" />
	<app main="Main" file="m2portHTML5" path="bin" />
	<window background="#FFFFFF" fps="60" />
	<window width="960" height="740" unless="mobile" />
	<window orientation="landscape" vsync="false" antialiasing="0" if="cpp" />

	<source path="src" />
	<haxelib name="openfl" />
	<haxelib name="actuate" />
	<library path="assets/ItemsLibrary.swf"  preload="true" />
	<library path="assets/complexLibrary.swf"  preload="true" />
	<library path="assets/buildingsLibrary.swf"  preload="true" />
	<icon path="assets/openfl.svg" />
	<assets path="assets/img" rename="img" />


package building;

import openfl.Assets;
import openfl.display.DisplayObject;
import openfl.display.Sprite;

class FloorSelect extends Sprite{

	private var floorSelect:DisplayObject;
	private var bg:DisplayObject;
	public function new() {
		addEventListener(Event.ADDED_TO_STAGE, addedHandler);
	private function addedHandler(e:Event):Void {
		removeEventListener(Event.ADDED_TO_STAGE, addedHandler);
		addEventListener(Event.REMOVED_FROM_STAGE, removedHandler);
		bg = Assets.getMovieClip ("ItemsLibrary:dynamicClass.ComplexBg");
		floorSelect = Assets.getMovieClip ("buildingsLibrary:dynamicClass.Build1");
	private function removedHandler(e:Event):Void {
		removeEventListener(Event.REMOVED_FROM_STAGE, removedHandler);

Sorry, I am new and little bit spamming :slight_smile:


What is the issue? Are there squares that aren’t displayed in the Flash target, or are they meant to be a different shape or color?

Can you “Export as Bitmap” from the Flash editor, and support your graphic that way? That will make it a bitmap, but guarantees it looks the way you want

Thanks, I tried fill simple solid color not bitmap-fill and it worked without “Export as Bitmap”