Problem running iOS version of app

Hi all, first time poster here…

I am building an app using HaXe Openfl. I’ve set it up on my PC and have been successfully creating it using Neko and Android targets through Flashdevelop. All of my files are synced to a mac via dropbox so I have also set up the system on a mac mini running Yosemite to try and compile to iOS.

Now, as I say, I have no issues using Neko on Windows 8 or my Android for running the application. I have Xcode 6.4 connected through a valid and up to date developer account to an iPhone 3GS (iOS 6.1.6) and an iPad running iOS 8.4. Running the project through to either of these devices OR the iOS simulator results in the same effect… it starts but it has a black screen and it appears to create some errors. The app must somewhat compile as Xcode says the build is successful, and it’s using the correct application icon on the homescreen.

The errors I see right now are as follows…

2015-08-02 17:03:23.907 RandomAcca[1005:2155061] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Could not load NIB in bundle: 'NSBundle </private/var/mobile/Containers/Bundle/Application/B57BE884-5462-4496-9755-802C3F88DD8D/> (loaded)' with name 'Main''
*** First throw call stack:
(0x29b46fef 0x38204c8b 0x29b46f35 0x2d5948a1 0x2d5963a5 0x2d428d0b 0x2d428097 0x2d432e19 0x2d42693b 0x30613ec9 0x29b0cfd5 0x29b0c299 0x29b0add3 0x29a57201 0x29a57013 0x2d228e17 0x2d223a09 0x233b57 0x387b6aaf)
libc++abi.dylib: terminating with uncaught exception of type NSException

All of the libraries are installed and up to date, I’ve removed and reinstalled Lime. I’ve used the lime update command to build the project for Xcode. I’d love to get some advice on where this could be going wrong, I’ve set the main interface to “Main” in the Deployment Info, and I’ve tried changing the deployment target and devices to all of their various options.

I’m happy to provide more info if someone can help me debug this situation, or point me in the right direction, but I don’t want to dump everything with most of it likely being irrelevant!

As a possible off-topic aside: I need on android and neko to run the build process with the -Dlegacy flag. I assume I need to do the same through XCode though I’m not sure how to include it if it’s required?

OK, I ran ‘Openfl build “project.xml” ios -Dlegacy’ before running it in XCode again and it seems to have compiled on the iPad and iPhone!

1 Like