Poll: Haxe 3.4.0 Testing

Hi everyone,

I’m looking for feedback on people who have tried OpenFL and Lime using the latest Haxe 3.4.0 release.

  • Tried it, works great
  • Tried it, some issues
  • Haven’t tried it

0 voters

Personally, I had strange errors when installing with the official Haxe 3.4 installer on Windows. I’m not sure if that file I downloaded when it was first released has been replaced or not.

In testing, things seem stable with a development build from near the same time, but I haven’t thoroughly tested against C++, which tends to be more susceptible to regressions.

Please comment if you’ve used the release, how it’s worked for you, what OS, etc, thank you :slight_smile:

3.4 rc2 is fine , when build with 3.4 ,it usually crash : stop to work or some xml parser error.

openfl test android -x -v -Dnext -debug
windows 10 ,64bit

@hpgood1 Do you have more details about that error?

I’m stuck on 3.2 because of https://github.com/HaxeFoundation/haxe/issues/5974#issuecomment-276483037 , but I’ll soon join

Most of the time i target windows / c++ … And there was a lot of issues with OpenFL when i started to try out Haxe 3.4 some time ago… many of them have been impoved and generally now it works pretty ok. However; there are many issues/bugs in OpenFL i still struggle with, but i’m not so sure these are related to Haxe 3.4 in specific.

Also, i’m stuck on Haxe 3.4 RC2 (2016-12-25_development_e08d018), because UDP sockets seem to be broken in 3.4 Release ( https://github.com/HaxeFoundation/haxe/issues/5987 ) :sweat: (udp works in rc2)

Haxe 3.4 Release also gives me the same kind of weird bugs that @singmajesty mentioned. 30% of the time i cant compile because of super stange issues that dont make no sense. Press compile again and it all works fine.

I’m currently using this build:


I think it’s basically the same as the 3.4 release, except I don’t get weird errors.

ok,I try it again in the next monday.


So what ::username:: think about Haxe 3.4 now?
Should I install stable build, or development build?

I’m running (with latest haxelib builds) on 3.4.0 stable build since few days after relase and so far everything works (mac native target). I guess, you will have to try, whether it works for your project.