OpenFL project fails after setting up FlashDevelop

I made a fresh installation of Windows 11 22H2 with also NVCleanstall to help me update Nvidia driver to latest that fixed a lot of game glitches and crashes but it is the Win reinstall that I needed about it since previously my attempt to rename AppData username although it worked and I edited registry paths, caused lots of permission errors apps like GIMP crashed because of permission errors in the Windows username folders. And for the same reason LIME config.xml probably did not generate.

I could have used VS Code but I still like using FlashDevelop as IDE for OpenFL project.

So my question is what is needed to set up all to work and to be able to run my previous neko/openfl projects to compile and run.

FlashDevelop Appman can install quite old Haxe version 3.4.7 or something but if I manually download the Haxe 4.2.5 it is newer. So I install Haxe Toolkit. (I use last version of the IDE before abandonment PHPDL - PHP Directory Lister) FlashDevelop-development

So since I manually install Haxe Toolkit, I read here

haxelib install lime
haxelib run lime setup
lime install openfl

How FlashDevelop (or HaxeDevelop) finds where Haxe is installed, do I need to manually browse the folder?

This thread is also any time returning to Haxe like that to know how to set it up.

*basically I had problems COMPILING. So programs that I have previously built before 2020 work with their EXE (lime has installed without problems). But what if I wanted to update and compile them again? I set Release: Neko and I get:

Called from lime/_internal/backend/native/NativeCFFI.hx line 613
Called from lime/system/CFFI.hx line 172
Called from lime/system/CFFI.hx line 306
Uncaught exception - Could not find NekoAPI interface.

if that matters I have C:\Users\Me\.lime\config.xml and is just

<section id="defines"> </section>

A SIMPLE project fails


import openfl.Assets;
import openfl.display.Bitmap;
import openfl.display.BitmapData;
import openfl.display.Sprite;
import openfl.Lib;

 * ...
 * @author Me
class Main extends Sprite 

	public function new() 
		// Assets:
		// openfl.Assets.getBitmapData("img/assetname.jpg");
		var iTestPic:Bitmap = new Bitmap(Assets.getBitmapData("img/testpic.jpg"));


By the way since Adobe Flash is no more, can neko builds still work, it is like a windows build right? Compiles with EXE file and so on.

To answer your last question, in my experiments I have had better luck compiling to Hashlink rather than Neko (on Mac, anyway). It is a newer virtual machine and will receive better support going forward.

OK if Neko is not possible anymore I need to know too, would save me time to not waste trying f it cant be done. But I read it could be because of improper XML for lime config mine is empty.

is it because on install Flashdevelop asks for Adobe flash player? Or it asks only for builds that uses it which neko does not.

If so, from OPENFL to windows is how? same way? I code in OpenFL then Release: Windows but then I get :

windows Error: 64bit is not automatically supported for this version of VC. Set HXCPP_MSVC_CUSTOM (i’d rather build for x86 to make it work on 32 bit too just in case like Windows emulators for phone)

There was a related forum post here: How to fix: Error: Set HXCPP_MSVC_CUSTOM manually - haxe-cpp - Haxe Community
I recommend reaching out to @BBartonW (who initiated that discussion) for help—he’s a nice guy.

Hi, you can make a debug with hashlink using a very simple command line “lime build hashlink…”. Neko VM is not good at performance and it seems to be stopped developing.

I tried using VS code I know it comes with a plugin for Haxe but I don’t like it for Haxe looks non native. In that case can I use FlashDevelop to make Windows build? So I make an OpenFL project the same way it has been done so far, I write the code there and make a windows build?

Hey You can easily create .exe files without using FD. Click on the cmd icon on FD UI, then you are able to run a cl like this “lime build windows -final -32”. You need to have Visual Studio installed on your computer for this task.

You can also make a debug with hashlink with my instructions above. The downside of this way is it has not breakpoints for checking errors but it seems to be ok when you have some issues with Neko VM.

I like trying to build windows but is the solution just ‘Use VS Code??’ I thought when this error HXCPP_MSVC_CUSTOM is “fixed” it is a way to build Windows using Flashdevelop/haxedevelop ?

I actually installed VS Community and some dev pack with it but not VS Code.