OpenFL installation issue on Mac OS Siera

Unable to install OpenFl as per instructions available on the getting started page. followed all the commands but it still keeps saying "Http connection timeout. Try running haxelib -notimeout to disable timeout
Tried the same but no success.

Hmm, which haxelib are you trying to install? Is it the haxelib install lime step?

Try and download it directly from here:

Then you can run haxelib install path/to/ (wherever your local file is located) and continue with the steps

Followed these steps:

  1. Download and install dmg file from
  2. Open terminal and run “bash haxelib setup ~/haxelib”
  3. haxelib install openfl
  4. haxelib run openfl setup

Here when it tries to download lime samples timeout error keeps on repeating.

I will try the steps shared by you. Thank you for the reply. Hope it works now.
404 Not Found

Code: NoSuchKey
Message: The specified key does not exist.
Key: builds/lime/
RequestId: 642C998349ECED5A
HostId: 6MmAcRfvaY/i42ASVAAFpLYX8xhtVlK+YhwXOar1dvpS7CcUqnGGEQ9T93gHBRIw0ru6FYwrImY=

Does this work? (sorry, in the midst of a server migration!)

yes, download in progress.

haxelib run openfl setup
lime is up to date
hxcpp is up to date
Downloading lime-samples-4,0,…
Download complete : 0 bytes in 10s (0KB/s)
Http connection timeout. Try running haxelib -notimeout to disable timeout

–>> This is the problem everytime

Hi again,

Sorry for the trouble!

I would like to make a single download for the install in the future. In the meantime, please try downloading from<project name> for any additional libraries you need (for example,

OK, I will try.


Not working:
macOS Sierra 10.12.6 (16G29)

-bash: openfl: command not found

Once you have the libraries installed, try haxelib run openfl setup again. At the end, it should install the “openfl” and “lime” commands.

“openfl” is a alias for “haxelib run openfl”, but all our documentation assumes the command is installed. Maybe we should change our setup command to install the shortcut first, and not last, so you have the command even if you finish installation another way :thinking:

1 Like

It works using haxelib run openfl

Thanks hopefully samples will also work.

By setting alias by using following command works
alias openfl=“haxelib run openfl”