Openfl deploy air throwing

Hi, I’m building for Air and after that I do : openfl deploy air
It is generating the dist directory with the .exe in it and everything runs.
The rar file isn’t showing up though. It also throws this:

openfl deploy air
Called from ? line 1
Called from CommandLineTools.hx line 1895
Called from CommandLineTools.hx line 22
Called from CommandLineTools.hx line 126
Called from CommandLineTools.hx line 641
Called from lime/tools/PlatformTarget.hx line 115
Called from AIRPlatform.hx line 155
Called from hxp/System.hx line 104
Called from hxp/System.hx line 157
Called from hxp/System.hx line 157
Called from hxp/System.hx line 155
Called from C:\HaxeToolkit\haxe\std/neko/_std/sys/FileSystem.hx line 68
Called from C:\HaxeToolkit\haxe\std/neko/_std/sys/FileSystem.hx line 59
Uncaught exception - [email protected]_file_type

It was working without throwing anything and generating both dir and rar file couple of days ago last I used it.

Here are the libs I’m using on the project:

actuate 1.8.9
datetime 3.1.3
extension-networking 1.4.2
haxeui-core git
haxeui-openfl git
hscript 2.4.0
hxIni 3.0.0
lime 7.8.0
openfl 8.9.7
hxcpp 4.1.15
haxe-strings 5.2.4

echo haxe 3.4.7

I tried :
openfl rebuild tools
and:
lime rebuild tools
but that wasn’t it.

It’s just this weird now…

Ok, so tried a verbose and checked it stopped at reading a .png with accentuation.
Probably an utf problem of some sort.
It literally stops just before compressing the files.
Everything before seems to work ok inside the dist directory.
If anyone actually knows how to make it plow through, would appreciate it.