Old CPU Regression

#21

Hmm , tried with qemu with intel2duo core “emulation” ( it only disables compile flags)
and it seems to work …

0 Likes

#22

Will I have still these problems if I compile for 32 bits instead ?

0 Likes

#23

Have you tried lime test linux -32 yet?

0 Likes

#24

Weren’t able to test it yet. I’ll post the results when I’ll have access to the computer :slight_smile:

0 Likes

#25

I was thinking of buying a computer with the same core and try to see what’s wrong and give you access by teamviewer if ever I don’t find a solution … but then I thought I could maybe buy you/openfl a computer with the same core so that you can see what’s wrong. What do you think ? :slight_smile:

0 Likes

#26

If we had a system locally we could test, then certainly we could help improve this. I am so sorry about the trouble in this! If you wanted to do this, a small system (like a NUC) would be much easier than a large system, but please know that I am not saying you have to do this.

0 Likes

#27

I was thinking about a laptop like this one. But there are other websites than amazon , in which country are you? ( and do you know other websites where we can buy refurbished/old computers ?)

0 Likes

#28

I’m in the US, but I’m trying to think which CPU features we’re looking (or not looking) for. Do you think it is a CPU that does not support SSE4? It looks like the T7250 is supposed to support SSE3?

If we got something, a ThinkPad (maybe there’s another) might be better, but I’m also asking locally if there is a system that might have similar specs

0 Likes

#29

Hi, finally, did you find a computer locally ?

( Didn’t see your question, but yes I would think so for the cpu)

0 Likes

#30

I was just able to test on an older system using an AMD Athlon 64 X2 3600+ processor.

CPUID says it has MMX(+), 3DNow!(+), SSE, SSE2, SSE3, x86-64, AMD-V.

The operating system is 32-bit Windows Vista.

The current Lime and OpenFL releases both work – though the test application crashes because the integrated graphics card has a problem with the shader used. Using -Dcairo runs without a crash.

0 Likes