No errors no compile windows [Solved]

image

Hi I am getting this strange behaviour when I want to build windows

I have no error, but the compile process just hangs

Have you tried building with -verbose so you can maybe see where it’s hanging?

/\\\_____________________________________________
////\_____________________________________________
/\_/\____________________________
/\_////\\_/\\_/\\\\
/\_/\_/\///\\///\___/\/////\_
_____/\_/\_/\_//\_
/\_/\\\\\___
/\_/\_/\_/\_/\_//\///////
________/\\\\_/\_/\_
/\_/\_//\\\\\__
///////////////////////////////_

Lime Command-Line Tools (7.7.0)

Initializing project…
Using project file: E:\Old School Games\NinjaSlash\NinjaSlash/project.xml
Reading Lime config: C:\Users\ladan_var.lime\config.xml

Running command: UPDATE

  • Running command: haxelib run openfl process C:\Users\LADAN_~1\AppData\Local\Temp/temp_4465493 C:\Users\LADAN_~1\AppData\Local\Temp/temp_12346066 -verbose “–targetDirectory=E:\Old School Games\NinjaSlash\NinjaSlash\bin\windows”
  • Detected host architecture: X64
  • Processing library: assets/startButton.swf [SWF]
  • Processing library: assets/systemPopup.swf [SWF]
  • Processing library: assets/gameAssetBundle.swf [SWF]
  • Detecting font name: Assets/fonts/Arial-Black.ttf -> “Arial Black”
  • Detecting font name: Assets/fonts/arial.ttf -> “Arial”
  • Detecting font name: Assets/fonts/arialbd.ttf -> “Arial Bold”
  • Detecting font name: Assets/fonts/economica.bold.ttf -> “Economica Bold”
  • Detecting font name: Assets/fonts/Engcomica.ttf -> “Engcomica”
  • Detecting font name: Assets/fonts/Roboto-Bold.ttf -> “Roboto Bold”
  • Detecting font name: assets/fonts/Engcomica.ttf -> “Engcomica”
  • Detecting font name: assets/fonts/Roboto-Bold.ttf -> “Roboto Bold”
  • Detecting font name: assets/fonts/arialbd.ttf -> “Arial Bold”
  • Detecting font name: assets/fonts/Arial-Black.ttf -> “Arial Black”
  • Detecting font name: assets/fonts/arial.ttf -> “Arial”
  • Copying template file: C:/HaxeToolkit/haxe/lib/openfl/8,9,6/assets/templates/haxe/ApplicationMain.hx -> bin/windows/haxe/ApplicationMain.hx
  • Writing file: bin/windows/bin/lib/startButton.json
  • Writing file: bin/windows/bin/lib/systemPopup.json
  • Writing file: bin/windows/bin/lib/gameAssetBundle.json
  • Writing file: bin/windows/bin/manifest/default.json

Running command: BUILD

  • Copying library file: C:/HaxeToolkit/haxe/lib/lime/7,7,0/ndll/Windows64/lime.ndll -> bin/windows/bin/lime.ndll
  • Running command: haxe bin/windows/haxe/release.hxml -D HXCPP_M64 -D no_console
  • Changing directory: bin/windows/obj
  • Running command: haxelib run hxcpp Build.xml -options “E:\Old School Games\NinjaSlash\NinjaSlash\bin\windows\obj\Options.txt” -DHXCPP_M64 -Dno_console -verbose
    __
    /\ \
    \ \ ___ __ _ ___ _____ _____
    \ \ _ \ /\ \/'\ /'___\/\ '__/\ '`\
    \ \ \ \ \/> <//\ _/\ \ \L\ \ \ \L\
    \ _\ _/_/_\ _
    \ \ ,/\ \ ,/
    /////////_/ \ \ / \ \ /
    \ _\ \ _\
    /
    / /
    /

hxcpp (Haxe C++ Runtime Support) (4.0.8)

Using makefile: Build.xml
Reading HXCPP config: C:\Users\ladan_var.hxcpp_config.xml
No specified toolchain

  • Parsing include: C:/HaxeToolkit/haxe/lib/hxcpp/4,0,8/toolchain/setup.xml
  • Parsing include: C:\Users\ladan_var.hxcpp_config.xml (section “vars”)
    Using Windows compiler: MSVC
  • Parsing include: C:/HaxeToolkit/haxe/lib/hxcpp/4,0,8/toolchain/finish-setup.xml
    msvs DevEnvDir=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE
    msvs FrameworkDir=C:\Windows\Microsoft.NET\Framework64
    msvs FrameworkVersion=v4.0.30319
    msvs INCLUDE=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\ATLMFC\include;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\include;C:\Program Files (x86)\Windows Kits\10\include\10.0.18362.0\ucrt;C:\Program Files (x86)\Windows Kits\10\include\10.0.18362.0\shared;C:\Program Files (x86)\Windows Kits\10\include\10.0.18362.0\um;C:\Program Files (x86)\Windows Kits\10\include\10.0.18362.0\winrt;C:\Program Files (x86)\Windows Kits\10\include\10.0.18362.0\cppwinrt
    msvs LIB=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\ATLMFC\lib\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\lib\x64;C:\Program Files (x86)\Windows Kits\10\lib\10.0.18362.0\ucrt\x64;C:\Program Files (x86)\Windows Kits\10\lib\10.0.18362.0\um\x64;
    msvs LIBPATH=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\ATLMFC\lib\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\lib\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\lib\x86\store\references;C:\Program Files (x86)\Windows Kits\10\UnionMetadata\10.0.18362.0;C:\Program Files (x86)\Windows Kits\10\References\10.0.18362.0;C:\Windows\Microsoft.NET\Framework64\v4.0.30319;
    msvs Path=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\Extensions\Microsoft\IntelliCode\CLI;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801\bin\HostX64\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\VC\VCPackages;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\TestWindow;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\bin\Roslyn;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Team Tools\Performance Tools\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Team Tools\Performance Tools;C:\Program Files (x86)\Microsoft Visual Studio\Shared\Common\VSPerfCollectionTools\vs2019\x64;C:\Program Files (x86)\Microsoft Visual Studio\Shared\Common\VSPerfCollectionTools\vs2019;C:\Program Files (x86)\Windows Kits\10\bin\10.0.18362.0\x64;C:\Program Files (x86)\Windows Kits\10\bin\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin;C:\Windows\Microsoft.NET\Framework64\v4.0.30319;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\HaxeToolkit\haxe;C:\HaxeToolkit\neko;C:\Program Files\TortoiseGit\bin;C:\Program Files\Git\cmd;C:\Users\ladan_var\AppData\Local\Programs\Fiddler;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\CMake\CMake\bin;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\CMake\Ninja
    msvs VCINSTALLDIR=C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC
    msvs WindowsSdkDir=C:\Program Files (x86)\Windows Kits\10\

I finaly got an error after runnin PowerShell in admin mode

C:/HaxeToolkit/haxe/lib/hxcpp/4,0,8/include\hxcpp.h(16): fatal error C1083: Cannot open include file: ‘typeinfo.h’: No such file or directory

Apparently this was a problem in Visual Studio version. As soon as I reverted to 2017 version the problem was gone.