Neko crash on in Openfl 4.3/4.2

openfl create PiratePig
openfl test neko -debug
results in
"Illegal instruction (core dumped)"
Happens on Openfl 4.3.0 / Lime 3.3.0 and Openfl 3.3.0 / Lime 3.2.1
Works with Openfl 3.6.1 / Lime 2.9.1

Failed to get more information with strace/gdb.

What host operating system are you using?

I knew i forgot some information :slight_smile:
Im using Ubuntu/Mint (16.04.1 LTS - 32bit) on a quite old laptop.
hxcpp is 3.3.49

I dont rely on neko but its quick/easy to test on.

Does a Linux C++ build also crash?

Yes, with the same error message:
Illegal instruction (core dumped)

Btw could i rebuild the lime.ndll with debug information to get maybe more information out of it?

gdb result

Thread 3 "PiratePig" received signal SIGILL, Illegal instruction.
[Switching to Thread 0xb63e9b40 (LWP 13028)]
0xb766fc8b in Resample_lerp32_SSE2 () from ./lime.ndll
(gdb) backtrace
#0  0xb766fc8b in Resample_lerp32_SSE2 () from ./lime.ndll
#1  0xb766e0e4 in MixSource () from ./lime.ndll
#2  0xb765b89c in aluMixData () from ./lime.ndll
#3  0xb76773a1 in ALCplaybackAlsa_mixerProc () from ./lime.ndll
#4  0xb7637ec7 in althrd_starter () from ./lime.ndll
#5  0xb7fa72b5 in start_thread (arg=0xb63e9b40) at pthread_create.c:333
#6  0xb7ce416e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:114

If you can use Lime from the source, perhaps you could edit the file “lime/project/lib/openal/include/config-linux-x86_64.h” and try commenting these lines before doing a build

Use lime rebuild linux, or if you have done so already (before removing these lines) lime rebuild linux -clean and try again

EDIT: It’s possible only SSE 4.1 supports need to be disabled, either way, this seems like a likely place to check. Thanks :slight_smile:

Just started to get the lime-dev build.
While realising that i am 11hours to late because jgranick already fixed it in git.

Still i went on to try it, but the build of lime fails with

./lib/sdl/src/video/x11/SDL_x11video.h:41:37: fatal error: X11/extensions/Xinerama.h: No such file or directory

Anyhow, i assume it would work now :slight_smile: