More md5 || more awd in away3d

Can anyone demonstrate it for me? I failed to bring in more animated mesh into my game, in md5 example i try to import another md5 file after hellknight.md5 but error, animation root node not found, i try create 2 var of loader3d, one for hellknight one for another md5 but got the same error
For awd, i used polarbear example, import another awd, but the 2nd awd can’t show, can anyone give me a hand?

I’m working on animators vs parsers right now, since there is some mess going on. So stay tuned although it can take some time…

But… in case of “animation root node not found” error, my guess is that you try to start animation like this:“node_0”);

Am I right? If yes, then you use a wrong animation name as function argument. Different models contain different animation names.

Please check what this line of code outputs in your case:

trace( "animation names: " + myAnimator.get_animationNames() );

beware that if there is no animation within file ( Away3d parser can’t see it ), animator during Initialization will throw error similar to this one:

haxe_ValueException {message: 'Cannot cast {\n\t_bufferContext : ,,,,,,,, \n\t_vertex…\t__name__ : away3d.core.base.SkinnedSubGeometry\n}', __previousException: undefined, __nativeException: haxe_ValueException, __skipStack: 2, value: 'Cannot cast {\n\t_bufferContext : ,,,,,,,, \n\t_vertex…\t__name__ : away3d.core.base.SkinnedSubGeometry\n}', …}

If you still see the error: “animation root node not found” despite using proper animation name, then it’s a data sharing failure.

Long story short - currently there are problems with interfaces that share data between file parsers and animators - I’m on it :slightly_smiling_face:

1 Like

klinek, can I send you my md5 model for testing?

Yes, sure. The more models for testing, the better. I will check if it’s loaded properly and animator starts.

In actionscript two different animated awd file can be import with two loader3d, i tried to import polarbear & ankba with two loader in away 3d openfl, but not working, why? Two md5 with two different loader not working as well, can anyone demonstrate for me if you can get it work