Malloc error with textfield in Neko

Hi all,

I’m getting the error below with even the most basic project I can come up with using a TextField:

Malloctest(2219,0x7fff72f6d000) malloc: *** error for object 0x102190eef: pointer being freed was not allocated *** set a breakpoint in malloc_error_break to debug

Now I run it a few times, I notice the hex id(?) of the object is always the same, in case that matters.

The source is below.
Whenever I comment either the line setting the text of the field or the line adding the field to the display list, the error does not occur.
The error does not occur compiling with -Dv2 or -Dlegacy.
The error does not occur on the Flash target.
Compiling with -Dhybrid generates a series of messages involving lime/openfl.utils.bytearray and openfl.utils.endian

So, I can compile but (I think) I want to know why it fails in some cases :slight_smile: .

The code:
package; import openfl.display.Sprite; import openfl.text.TextField; class Main extends Sprite { public function new () { super (); var tf:TextField = new TextField(); tf.text = "hallo"; addChild( tf ); } }
Running OSX with Haxe 3.2.1 with haxelib libraries as below.

Mannos-MBP:lib manno$ haxelib list
actuate: [1.8.6]
box2d: [1.2.3]
hxcpp: [3.2.205]
layout: [1.2.1]
lime-samples: [2.6.0]
lime: [2.9.1]
openfl-samples: [3.3.1]
openfl: [3.6.1]
swf: [2.2.0]

Using lime 2.9.0 worked for me.

Someone also opened an issue on github:

Thanks, that fixed it.