Lime version lime may not be compatible with OpenFL openfl (expected version 7.2.*)


#1

I haven’t used OpenFL for a while (may a couple of months or so) and tried to create a new project. I ran openfl upgrade and also haxelib update and now I’m getting this while running openfl create project [project-name]:

Warning: Lime version lime may not be compatible with OpenFL openfl (expected version 7.2.*)
Use <lime version="" /> before <haxelib name="openfl" /> to include a specific version

The message is really wierd. I tried to uninstall and install openfl but this message remains.

Any suggestions?

I’m using Arch Linux
Haxe Compiler 3.4.7
Lime Command-Line Tools (7.2.0)
OpenFL Command-Line Tools (8.7.0-LmSvzX)


#2

I believe this is fixed in OpenFL 8.8.0, released yesterday :slight_smile: