"Lime test windows" command not working, please help

I was watching a tutorial (https://www.youtube.com/watch?v=cZEnYCUSJ2E At 1:36) on how to build a game to create a mod for FNF Kade Engine. It says that to build a game I have to make the command ‘‘lime test windows’’. It “worked” but not in a way I wanted it to, what’s supposed to happen is it basically “makes the game window” and I can access it via project.xml (I’m new to this so sorry if I sound dumb) so I ran the command but all I keep getting is this:


What do I do? Again I’m new to this and stuff and really want to learn, thanks for reading :slight_smile:

Also here’s the Github for the source code I’m using to create the game window: https://github.com/KadeDev/Kade-Engine

Never mind, found out how to fix it
All I had to do was do the following commands on my command prompt:
“haxelib install lime”
and
“haxelib install flixel”

I thought I had lime installed onto my computer which I technically did since setup.bat WAS supposed to do that, however apparently not so on a complete guess/whim I decided to do that and it worked, I had less “telling me what’s wrong” code.
I also didn’t know what the “flixel” program was but found out it was something I needed and since it was saying that Flixel was missing I decided, again, to go on a whim/guess and try to install flixel and when I ran “lime test windows” it worked :smiley:

can u help me when i type lime test windows it says (source/TitleState.hx:61: characters 16-28 : Type not found : APIStuff
C:/HaxeToolkit/haxe/lib/polymod/git/polymod/format/XMLMerge.hx:189: characters 10-23 : Warning : This typedef is deprecated in favor of haxe.xml.Access)

My problem is that the video here: https://www.youtube.com/watch?v=cZEnYCUSJ2E
Said that I needed to choose a default IDE but the option to choose didn’t show up.