Lime.system.System error

I manually compiled Haxe and Neko on FreeBSD 10.2 x86_64. I tried phaser library yesterday and is working fine.
Today when I try to install openfl, there is an issue. haxelib install openfl worked fine, but haxelib run openfl gave issues:

[[email protected] ~/Dev]$ haxelib run openfl setup
haxe/Timer.hx:199: characters 7-25 : Type not found : lime.system.System
/home/agnis/haxe/lib/haxe/extra/haxelib_src/src/tools/haxelib/Main.hx:54: lines 54-100 : Defined in this class
/home/agnis/haxe/lib/haxe/extra/haxelib_src/src/tools/haxelib/Main.hx:89: characters 13-24 : Class<haxe.Timer> has no field stamp
Library lime is not installed

Shouldn’t lime be automatically installed like all other dependencies? I installed lime with haxelib install lime and then tried the above again. This time same error minus lime not installed complain and then everything stucks.
Any manual way of installing? Given haxelib is downloading and extracting packages fine, would installing all packages lime and openfl depend upon would work?
It looks like haxelib run is not working, what should be used to execute openfl command after such installation?
HAXE_STD_PATH is "/home/agnis/haxe/lib/haxe/std:."
HAXEPATH is "/home/agnis/haxe/bin"
HAXELIB_PATH is “/usr/lib/haxelib”

Have you tried the install script from www.openfl.org/download yet? :slight_smile:

I did some changes. I made the structure of Haxe install same as Linux Haxe. Current settings:

HAXE_STD_PATH is "/home/agnis/bin/haxe-3.3.0/std:."
HAXEPATH is "/home/agnis/bin/haxe-3.3.0"
HAXELIB_PATH is “/usr/lib/haxelib”

Everything was working fine. openfl donwloaded. haxelib run openfl setup successfuly downloaded and installed lime. But then I ran into this issue:

  Current version is now 2.6.1
Done
Called from lime/system/System.hx line 694
Called from lime/system/System.hx line 371
Called from lime/system/System.hx line 481
Called from lime/system/System.hx line 306
Called from /usr/lib/haxe/std/neko/Lib.hx line 30
Uncaught exception - load.c(237) : Failed to load library : lime.ndll (Shared object "lime.ndll" not found, required by "neko")

I checked /usr/lib/haxelib/lime/2,6,1/ndll and I found this:

[email protected]:/usr/lib/haxelib/lime/2,6,1/ndll % ls
Android        Emscripten    Linux64        Mac64        iPhone
BlackBerry    Linux        Mac        Windows

There is no build for FreeBSD??? I know FreeBSD is not a supported platform, but any way to build it myself?

There is a chance that it is all set up properly, but it cannot run the binaries on your system. Please check the following and see if it returns the correct paths:

haxelib path openfl
haxelib path lime

If we’re sure it’s because the builds (we use Ubuntu 12.04 for Linux builds to keep an older glibc version) are not compatible, we could try building from source. If you want to try, please follow the instructions here:

https://github.com/openfl/lime/blob/master/README.md#building-from-source
https://github.com/openfl/openfl/blob/master/README.md#development-builds

When I installed haxe & openfl in my Linux Fedora 21 64bit I got lots of error when I placed haxe on /usr/lib64 which is typically different from the suggested location of /usr/lib. Try to use binaries and install it all at /usr/lib?

These helped me by the way 1. haxe_installer and this site install openfl.