Lime rebuild stopped working


So after experimenting with different lime versions, on neko I stopped receiving the stack trace on crash. I thought that I’d rebuild lime to fix it, but I’m now unable to do so. The building process just doesn’t start:

lime rebuild windows -clean -v

/\_ \    __
\//\ \  /\_\    ___ ___      __
  \ \ \ \/\ \ /' __` __`\  /'__`\
   \_\ \_\ \ \/\ \/\ \/\ \/\  __/
   /\____\\ \_\ \_\ \_\ \_\ \____\
   \/____/ \/_/\/_/\/_/\/_/\/____/

Lime Command-Line Tools (2.9.1)

Initializing project...
Reading HXCPP config: C:\Users\abyss\.hxcpp_config.xml
Using target platform: WINDOWS

Running command: REBUILD

But I’m able still to build my HaxeFlixel projects for both neko and hxcpp.
I tried to reinstall lime from haxelib (doesn’t help) and to ‘rebuild tools’ (doesn’t work just like ‘rebuild windows’).
Any clues what can be done here to get it working?

It might be your current working directory. The lime rebuild command can build other libraries, such as:

lime rebuild hxcpp windows
lime rebuild path/to/hxcpp windows
lime rebuild path/to/hxcpp/project windows


cd path/to/hxcpp/project
lime rebuild windows

When no project is specified, it defaults to building itself, but depending on the directory you run the command, it could be building something else

I tried now to change the current directory to the one not containing any project and also to the one that contains lime itself. Tried Haxe 3.2.1 and Haxe 3.4-rc2. Tried Lime 3.5.2. But it’s the same: the command does something for a second or two and then exits.
Is there a way to clean all caches involved for lime, besides the -clean flag and removing from haxelib?

Tried also renaming the hxcpp cache directory - doesn’t help. I think I might have upgraded something on haxelib recently, but what it might be? How to debug what causes the trouble?

Thank you

Are you using a haxelib release of Lime (which does not support a rebuild), or have you cloned Lime from GIT?

I used both. Now that you said about it, I rebuilt lime which is set to git in haxelib successfully.
So the problem in the title is resolved, thank you for insight!

About the call stack, I get just the line AL lib: (EE) alc_cleanup: 1 device not closed in HaxeDevelop. But lime test neko outputs the call stack. So, it has something to do with HaxeDevelop.