Lime not working in Visual Studio Code when installing Haxe 4

please help, I get the following error in visual studio code version 1.4 after I install Haxe 4.0.2 (same applies to any Haxe 4 subversion):

here is the full error:

this causes Lime commands to not work, when I try to test the project with command, for example:

lime test HTML5

nothing happens, no errors or any messages, same happens if I try any other commands such as lime setup

if I uninstall Haxe 4 and downgrade to Haxe 3.4.7 it works perfectly

I am using the latest libs for Lime, OpenFL and Flixel

I tried to google the error but not many resources and the other solutions did not work for me, I found one similar that suggested using visual studio code v1.3 but i think it was for an older version of lime

Best Regards

What about lime -verbose from a command-line?

I get this error from windows command line

in visual studio code nothing happens, the command just fail silently

I will try to run on a different machine as well and let you know

Oh try running haxelib run openfl setup -alias again

Haxe 4 has changes to Neko which broke the command alias shortcut

1 Like

thank you very much, that fixed it.