Library swf version dev does not have a run script

after getting errors on latest release via MovieClip.__constructor I tried the latest master in dev mode, I’m getting the following error on my Windows machine with latest openfl, and lime 8.0.0

Error: Library swf version dev does not have a run script
Error: Could not process asset libraries (swf)

the first error appears when i try haxelib run swf too.

On my mac I get a completely different error, although the swf command works

Error: Invalid field access : length

I was directed to the swf readme, which mentions calling haxe rebuild.hxml and now my windows pc works, while my mac has a ton of errors, I’ll post them here in a minute, after testing some things

grabbing lime and openfl develop branches fixed this, I need lime 8 and openfl 9.1 for work, but I can just do WORK work on my windows machine, and personal work on my mac (which is the only machine that has Animate installed). All is good.

still not sure why lime 8.0.0 and openfl 9.1.0 work with the latest git version of swf on my windows machine, though