Issues with lime preloader

Hi guys, so i just built my game and i tried to run it but i got this error [] ERROR There is no asset library with a id of “default” and i dont even have a preloader right now. Please help.

Do you use openfl.utils.Assets at all? Do you have any <assets /> tags in your project.xml? If so, could you share them?

i do have some assets in my project.xml

<assets path="assets/data" include="*.oel" />
	<assets path="assets/images" include="*.png" />
	<assets path="assets/sounds" include="*.wav" />
	<assets path="assets/music" include="*.mp3" if="flash" />
	<assets path="assets/music" include="*.ogg" unless="flash" />

That’s curious, there’s a default preloader that should load these assets for you. Which version of OpenFL and Lime are you using? Does it work on other platforms/targets?

I don’t know about other targets but i tried it on windows it does not work. And how can i check the version.

Try haxelib list and see what it outputs, maybe share it here?

i am using openfl 8.0.2 and lime 6.2.0.

Do you have a way to test a newer version of OpenFL and Lime? It’s hard to tell if this is might be an issue that’s been resolved already

I don’t know, because i don’t want to update it and some of my code not being supported and it is alot of codes.

What target are you having a problem with? Does every target (HTML5, Flash, Neko, etc) throw this same error?

Can you try an OpenFL sample (such as openfl create DisplayingABitmap && cd DisplayingABitmap && openfl test neko) and see if it has the same runtime error?

EDIT: Also, I think you can do <assets path="assets/images" include="*.jpg|*.png" /> to combine filters

It only happens when i build the project. Also my target is windows

i see you are not really getting my point. This problem only happens after i build my game. Debugging/testing as no problem. Also i did not put any preloader code in the game so i dont get why it will even give me that error.