Is building for iOS11 even possible?

My publisher is requesting a feature that is only available in the newest ios sdk: 11. My game currently builds for iOS6. Not only that, I’m locked into openfl legacy (the highest stable build before openFL next came along)

I tried building for ios 11 and was met with:

ld: -ios_version_min argument is missing period as second character
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Something tells me it’s not really possible, but I wanted to make sure.

Can you tell where the flag is being passed? Can you open the generated Xcode project, and see if it has recommendations for updating the project settings?

EDIT: Also, could you try using a current version of OpenFL (“DisplayingABitmap” or another basic sample) and see if it throws the same message?

Here is a pastebin of the full segment that causes the error:

I’m not well versed in the guts of the build process, so I’m not sure I’d be able to tell where the flag is being passed.

currently running a re-build in the generated xcode project to see what pops up. will report back soon. Thanks!

xcode suggests these project settings:

I performed the changes, but am now receiving errors about going past ios 9.x
…which I believe need to update xcode for. and I’m not sure that’s a change I’m comfortable making at the moment (currently on xcode 7)

It appears it is using the iPhoneOS9.2 SDK, which may not be compatible with iOS 11, I’m unsure of what changes Apple has made, but updating Xcode in order to target a newer iOS version is a “time honored” tradition :stuck_out_tongue:

I can build to android and iOs 9.3.3 with this haxelib versions:

C:\Windows\system32>haxelib list
haxelib_client: [3.2.0-rc.3]
lime: [2.5.2]
openfl: [3.2.2]
//------------------Additional libs
extension-android-support-v4: [1.0.0]
extension-googleplaygames: [1.3.3] //Google Play Services
extension-googleplayservices-lib: [1.1.0]
haxe-ga: [0.5.2] //Google Analytics
hxcpp: [3.3.49]

openfl-unityads: [1.0.7] //UNITY ADS for android and iOs
samcodes-admob: [1.0.9] //ADMOB for android and iOs
samcodes-chartboost: [1.0.1] //CHARTBOOST for android and iOs

project.xml must have:
<android minimum-sdk-version=“10”/>
and your android sdk version of “Google Play Services” must be = 21, for GooglePlayServices to work

when i have tried with newer lib versions (lime, openfl, etc) they crash