[iOS] Simulators don't appear as build option since Xcode / macOS update

Since I reinstalled Xcode to version 12.2 and macOS to Catalina, the simulators don’t appear as a run destination in Xcode.

simulators_missing

If I click on “Add Additional Simulators”, the list of simulators I have installed appears.

I have tried duplicating the target, creating a new scheme, and updating the haxelibs to latest openfl 9.0.2, lime 7.8.0 and hxcpp 4.1.15.

Also, running lime test ios -simulator doesn’t work, and it never has for me, but I would just open the project in Xcode and compile/run from there. There is an additional warning message now, warning: The iOS Simulator deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 9.0 to 14.2.99.

I’ve been able to get around the problem by building for a device, selecting a warning that appears saying “Update to recommended settings”, and accepting those settings. Now the simulators appear again.

@Vasco If you could do the following, it would really help!

1.) Run lime update ios -xcode to generate your project and open it in Xcode, and hit save.
2.) Go back to the “bin/ios” directory and copy it somewhere safe
3.) Click the “Update to recommended settings” option in Xcode
4.) Use Meld (or another merge tool) to compare the new Xcode project to the old one… or perhaps post both of them up where we could see them

It is important that the original template be opened in Xcode and saved again (before updating to recommended settings) because every version of Xcode has it’s own way of reordering the contents of the project file. Then it should be possible to compare and see what is actually being added or changed to resolve issues

Thank you :smiley:

Sure, glad to help!

I wasn’t able to save the Xcode project since the option was grayed out. It does seem that some of the contents were reordered. I’m not sure which changes are relevant, here are the files:

http://www.seriusgames.com/Misc/project_original.pbxproj
http://www.seriusgames.com/Misc/project_recommended_settings.pbxproj

Let me know if there’s something I can do to save the project, I tried changing some of the settings but even then the save option seems unavailable :confused:

Speaking of xcode, there is a warning now when I build the project, everything is working fine so far.
Should I start to worry? :slight_smile:

OpenGLES is deprecated. Consider migrating to Metal instead.

Btw, about simulator, openfl sets target ios to 8.0, while “Update to recommended settings” set version to 12.0.
Most likely, that the reason of empty simulators list.