[iOS] -lstd not found for "Archive"

After I uploaded the build of our game, I’ve received a warning from Apple, saying that since Feb 2015 the builds should be arm64 (or something like that), I tried to add “arm64” as Valid Architecture in Xcode; but I get the following error:

ld: library not found for -lstd
clang: error: linker command failed with exit code 1 (use -v to see invocation)

This problem only occurs when I try to Archive the build (in other words, when I use the Release configuration). I don’t know where is that library. Someone knows a workaround for this issue?

Thanks in advance

We don’t support x64 for iOS, just yet, but this is planned – as I know they will start rejecting submissions in a couple months if we don’t. Any help in these regards are of course welcome, otherwise it’s on the list :smile:

The issue here is that the HXCPP libraries need to be built for x64 as well. We will probably need a naming scheme for x64 on iOS, and handle this properly in our tools to copy the ones that are expected.

Hi, I was just building for iOS and thought I’d look around.

I did a lime update ios -debug which updated the XCode project and from there I was able to change the Architectures on the Build Settings from armv7 to Standard architectures as below.

I was then prompted to change the Deployment Target to 5.1.1 which supports 64bit build slices. After that everythings seems to build and run fine (but I’m not on a 64bit device).

I tried to create an Archive and that seemed to create ok (not tested though). Also I’ve not gone through any Apple submission to verify it’s okay.

Thought I’d share my experience to see if it helps in any way.



Yes, you won’t find any trouble when building for debug. You’ll get a warning when you submit the archive for the Appstore. Now is a warning, but from Feb 2015 the apps that don’t support arm64 will be rejected.
Also, you should add “arm64” to the option “Valid Architectures”.